SonarQube Scanner - sonar.issue.ignore not working

Hi there,

I’m using the dotnet-sonarscanner in order to scan my .NET core project. Although I have multiple parameters in my settings file (SonarQube.Analysis.xml ) to ignore some rules that I don’t want to follow from this project’s quality profile, they’re not working at all…

Here’s an example of the settings file that I’m trying to use:

<?xml version="1.0" encoding="utf-8" ?>
<SonarQubeAnalysisProperties  xmlns:xsi="" xmlns:xsd="" xmlns="">

    <Property Name=""></Property>

    <Property Name="sonar.issue.ignore.multicriteria">e1</Property>
    <Property Name="sonar.issue.ignore.multicriteria.e1.ruleKey">squid:S3717</Property>
    <Property Name="sonar.issue.ignore.multicriteria.e1.resourceKey">**/*</Property>

Thank you, in advance.

P.S: I would rather ignore those issues without using the UI since I don’t have admin privileges.

Hi Dinis,

Modifying sonar.issue.ignore.multicriteria is not officially supported and will not change list of reported issues. This setting is not processed by the scanner, but by the SonarQube itself from it’s configuration. If you need to change list of reported rules, you’ll need to modify relevant .ruleset file in \.sonarqube\conf\ directory after begin step, before the build is triggered.