SonarQube Pull Request Decoration with Azure DevOps after Upgrade to

Hi there,

we’re using sonar qube to decorate our pull requests in a azure devops server. Until the update to it worked fine. However after the update PRs don’t get decorated anymore, although the task reports success. In the Pull Request, the quality gate results are displayed as Waiting:

Interestingly, the log states, the connection were not configured which is very odd. Firstly, because it worked before the update and secondly because the configuration appears to be all right:

However the compute engine log contains entries like the following, stating no devops platform were configured:

2023.07.31 13:52:59 DEBUG ce[AYmry1LYWNA1FLviLFbf][o.s.d.c.C.insert] ==> Parameters: AYmry13-JtlOF9lcp1sw(String), AYmry1LYWNA1FLviLFbf(String), No devops platform configured. To report the Quality Gate status to a devops platform, please configure it in the project administration.(String), GENERIC(String), 1690804379134(Long)
2023.07.31 13:52:59 DEBUG ce[AYmry1LYWNA1FLviLFbf][o.s.d.c.C.insert] <== Updates: 1
2023.07.31 13:52:59 INFO ce[AYmry1LYWNA1FLviLFbf][o.s.c.t.p.a.p.PostProjectAnalysisTasksExecutor] Pull Request decoration | status=SUCCESS | time=3ms
2023.07.31 13:52:59 INFO ce[AYmry1LYWNA1FLviLFbf][o.s.c.t.p.a.p.PostProjectAnalysisTasksExecutor] Report branch Quality Gate status to devops platforms | status=SUCCESS | time=0ms
2023.07.31 13:52:59 DEBUG ce[AYmry1LYWNA1FLviLFbf][o.s.c.a.AnnotationConfigApplicationContext] Closing org.springframework.context.annotation.AnnotationConfigApplicationContext@5c03179f, started on Mon Jul 31 13:52:56 CEST 2023, parent: org.springframework.context.annotation.AnnotationConfigApplicationContext@7642ef44

So for some reason, the configuration does not work.

I’ve already tried to update the Personal Access Token and also removed and re-added the DevOps Platform Integration completely.

Both Azure DevOps and SonarQube are installed on premise. The agents are also on prem machines.

What did I miss?

Must-share information (formatted with Markdown):

Found it. The project settings were not configured.

Couldn’t sse them though, because I didn’t have the permission. Had to change the permission template and apply it on the project to be able to see the configuration.

Now works like a charm.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.