Sonarqube:lts-community AD auth how to use in OpenShift(k8s)

  • Deployed from dockerhub image: sonarqube:lts-community
  • Deployed with own custom dc-yaml no helm-chart used!
  • Problem: ActiveDirectory-auth not working (connection failure):
    Caused by: javax.naming.CommunicationException: simple bind failed:
  • Trying to: change our LDAP-auth into companys AD-auth with the relevant information.
  • What done: opened relevant fw and network policies and filled the as:
    LDAP ( and
    Active Directory Setup With SonarQube - SonarQube - Sonar Community (
    companys CA-certs as mount-volumes into Deployment also tried to put them via ENV (trustStore) like ES_JAVA_OPTS, SONARQUBE_WEB_JVM_OPTS or SONARQUBE_CE_JVM_OPTS.

As above the exception and dc-pod termination due to error:
Caused by: javax.naming.CommunicationException: simple bind failed:
Not sure if I misunderstood LDAP/AD -settings or if the connection trust is not valid. I tested that, from the same k8s-namespace should have working LDAP/AD-connection tested with custom LDAP-image with general-searching script inside - works fine. The test-pod has also the same CA-certs of coures.

Thank You in advance to anyone who can uplift our problem or provide any kind of tips for testing.

BR, Vince.

Hey there.

My first suggestion would be running an SSLPoke from your container, making sure that the Java executable / truststore running SSLPoke is the same as the one running your SonarQube server. This should help you understand if the certs are correct (and it’s a SonarQube problem) or if the certs are incorrect (making it something to solve at the Java layer).

1 Like

Hi Colin!
As you said good to SSLPoke-check it. Certs worked when we added this property: to truststore.

Thank you for response and have a great summer! :+1:
BR. Vincent

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.