SonarQube helm installation does not suceed

I have tried installing the SonarQube 7.6 helm chart on a Kubernetes 1.12 cluster, but it doesn’t seem to complete successfully.

Full log:

iadar@mbp:~$ kubectl create namespace sonarqube
namespace/sonarqube created
iadar@mbp:~$ helm install stable/sonarqube --namespace sonarqube
NAME:   kissable-shark
LAST DEPLOYED: Mon Apr  1 10:15:05 2019
NAMESPACE: sonarqube

==> v1/PersistentVolumeClaim
kissable-shark-postgresql  Pending  3s

==> v1/Service
NAME                       TYPE          CLUSTER-IP    EXTERNAL-IP    PORT(S)         AGE
kissable-shark-postgresql  ClusterIP  <none>         5432/TCP        3s
kissable-shark-sonarqube   LoadBalancer  9000:31221/TCP  2s

==> v1beta1/Deployment
kissable-shark-postgresql  1        1        1           0          2s
kissable-shark-sonarqube   1        1        1           0          2s

==> v1/Pod(related)
NAME                                        READY  STATUS   RESTARTS  AGE
kissable-shark-postgresql-5bd6f7dbbc-jwnx8  0/1    Pending  0         2s
kissable-shark-sonarqube-55d9c687c5-k9mvz   0/1    Running  0         2s

==> v1/Secret
NAME                       TYPE    DATA  AGE
kissable-shark-postgresql  Opaque  1     3s

==> v1/ConfigMap
NAME                                      DATA  AGE
kissable-shark-sonarqube-config           0     3s
kissable-shark-sonarqube-copy-plugins     1     3s
kissable-shark-sonarqube-install-plugins  1     3s
kissable-shark-sonarqube-tests            1     3s

1. Get the application URL by running these commands:
     NOTE: It may take a few minutes for the LoadBalancer IP to be available.
           You can watch the status of by running 'kubectl get svc -w kissable-shark-sonarqube'
  export SERVICE_IP=$(kubectl get svc --namespace sonarqube kissable-shark-sonarqube -o jsonpath='{.status.loadBalancer.ingress[0].ip}')
  echo http://$SERVICE_IP:9000

iadar@mbp:~$ kubectl get svc -w kissable-shark-sonarqube
Error from server (NotFound): services "kissable-shark-sonarqube" not found

Looking inside, I see this for kissable-shark-postgresql-5bd6f7dbbc:

pod has unbound immediate PersistentVolumeClaims (repeated 3 times)

I have the same error.

$ kubectl get pods

capture the pod name:

$ kubectl logs wishful-uakari-sonarqube-59d759d49c-zwgks

2019.05.29 21:34:50 INFO app[o.s.a.AppFileSystem] Cleaning or creating temp directory /opt/sonarqube/temp
2019.05.29 21:34:50 INFO app[] Elasticsearch listening on /
2019.05.29 21:34:50 INFO app[o.s.a.p.ProcessLauncherImpl] Launch process[[key=‘es’, ipcIndex=1, logFilenamePrefix=es]] from [/opt/sonarqube/elasticsearch]: /opt/sonarqube/elasticsearch/bin/elasticsearch
2019.05.29 21:34:50 INFO app[o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
2019.05.29 21:34:50 INFO app[o.e.p.PluginsService] no modules loaded
2019.05.29 21:34:50 INFO app[o.e.p.PluginsService] loaded plugin [org.elasticsearch.transport.Netty4Plugin]
2019.05.29 21:34:55 WARN app[o.s.a.p.AbstractProcessMonitor] Process exited with exit value [es]: 137
2019.05.29 21:34:55 INFO app[o.s.a.SchedulerImpl] Process [es] is stopped
2019.05.29 21:34:55 INFO app[o.s.a.SchedulerImpl] SonarQube is stopped

Hope someone has a good solution here.

1 Like

@kevinckw i got the same error running on my kubernetes cluster, to solve it, i just add se following config:

# Set security context for sonarqube pod
  fsGroup: 999
  runAsUser: 999

Worked like a charm!

Chart Version: 1.0.4
Helm Version:
Client: &version.Version{SemVer:“v2.13.1”, GitCommit:“618447cbf203d147601b4b9bd7f8c37a5d39fbb4”, GitTreeState:“clean”}
Server: &version.Version{SemVer:“v2.13.1”, GitCommit:“618447cbf203d147601b4b9bd7f8c37a5d39fbb4”, GitTreeState:“clean”}
Kubernetes Version:
Client Version: version.Info{Major:“1”, Minor:“14”, GitVersion:“v1.14.1”, GitCommit:“b7394102d6ef778017f2ca4046abbaa23b88c290”, GitTreeState:“clean”, BuildDate:“2019-04-08T17:11:31Z”, GoVersion:“go1.12.1”, Compiler:“gc”, Platform:“linux/amd64”}
Server Version: version.Info{Major:“1”, Minor:“13+”, GitVersion:“v1.13.6-gke.0”, GitCommit:“14c9138d6fb5b57473e270fe8a2973300fbd6fd6”, GitTreeState:“clean”, BuildDate:“2019-05-08T16:22:55Z”, GoVersion:“go1.11.5b4”, Compiler:“gc”, Platform:“linux/amd64”}

I have the same problem sad.

2019.08.02 03:15:51 INFO app[o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
2019.08.02 03:16:01 WARN app[o.s.a.p.AbstractManagedProcess] Process exited with exit value [es]: 137
2019.08.02 03:16:02 INFO app[o.s.a.SchedulerImpl] Process[es] is stopped
2019.08.02 03:16:02 INFO app[o.s.a.SchedulerImpl] SonarQube is stopped