Sonarqube fails to start with ./sonar.sh: line 431: Operation not permitted error

Hi, I encountered the following error with a completely-fresh installation:

  • Versions used SonarQube: 9.0.1 Community Edition, RHEL8, Java 11.0.12 2021-07-20 LTS, PostGRE 10.
  • Error observed: When starting Sonarqube on a fresh install using the basic start script, logged in as the sonarqube user it produces

[sonarqube@[…] linux-x86-64]$ ./sonar.sh start
Starting SonarQube…
./sonar.sh: line 431: /opt/sonarqube-community/sonarqube-9.0.1.46107/bin/linux-x86-64/./wrapper: Operation not permitted
Failed to start SonarQube

  • steps to reproduce:
    Unzip sonarqube,
    set appropriate JDK locations,
    create sonarqube user,
    set RUN_AS_USER=sonarqube
    change ownership of sonarqube-community directory to sonarqube:sonarqube and make items within it executable
    Attempt to start Sonarqube
    Error is encountered, nothing is written to logs other than what’s displayed in the terminal.

Line 431 in sonar.sh is:

eval $COMMAND_LINE

within the context

start() {
echo “Starting $APP_LONG_NAME…”
getpid
if [ “X$pid” = “X” ]
then
# The string passed to eval must handles spaces in paths correctly.
COMMAND_LINE="$CMDNICE “$WRAPPER_CMD” “$WRAPPER_CONF” wrapper.syslog.ident=$APP_NAME wrapper.pidfile="$PIDFILE" wrapper.daemonize=TRUE $ANCHORPROP $IGNOREPROP $LOCKPROP"
eval $COMMAND_LINE
else
echo “$APP_LONG_NAME is already running.”
exit 1
fi
getpid
if [ “X$pid” != “X” ]
then
echo “Started $APP_LONG_NAME.”
else
echo “Failed to start $APP_LONG_NAME.”
fi

I’m not sure what else I could look at to troubleshoot this.

  • potential workaround: unknown

Update on this:
This is related to the fapolicyd service.
Running Service disable fapolicyd
Temporarily will enable SQ to start right up.

1 Like

Hi,

I’m glad you worked through this and thanks for the followup. I’m sure it will help future users.

 
Ann