SonarQube connection cannot be created in WSL Remote Development

  • Operating system: Windows 10 / Ubuntu 20
  • SonarLint plugin version:
  • Programming language you’re coding in: Java
  • Is connected mode used: trying to
    • Connected to SonarCloud or SonarQube (and which version): Enterprise Edition, Version 9.7.1 (build 62043)

I am using the new IntelliJ IDEA Remote Development to connect to WSL with Ubuntu 20. When I try to configure the SonarQube connection, I cannot open the pop-up. The plus icon doesn’t do anything. Not sure if this is something to be fixed in your plugin or in IntelliJ’s Remote Development itself.

1 Like

I’m facing the same issue, with different software versions.

  • SonarLint:
  • OS: Windows 10 (19045.2486) / WSL Ubuntu 22.04.1 LTS

Hello @Filip_Kittnar and @kad-bosd,

Sorry for the late answer. Would you have any other details to provide ? Is there any error that happens in the IDE (red exclamation mark at the bottom right of the window), in SonarLint Logs or in IDEA logs ?

Please note that we don’t officially support WSL for now

Hi Damien,

Thanks for your reply.

I can’t get IntelliJ to tell me anything. No errors in the IDE and no leads in the logfiles. It looks at though the plus icon does nothing, as Filip mentioned before.

Also, the Verbose output and Analysis logs don’t appear in the tool windows setting.


I have the same issue with remote development on macOS.

Also Verbose output and Analysis logs don’t appear in the tool windows setting for me as well. idea logs shows no error.

Hello, it seems that we got a little further in the latest version of IDEA (2023.1.2) and the latest version of the plugin. The plus icon now opens the window and I can do the configuration. However it doesn’t persist and once I save it, it against shows the alert that the Sonar binding isn’t correctly configured and once I open the configuration, it is again completely empty - not even the Sonar connection is configured.

OK, I take that back. It was just some conflict with the configuration done on the same project from a different instance of IntelliJ (opened straight in WSL via Xserver). When I removed the old configuration I managed to save the new one.
And it works.
The only small issue: the analysis doesn’t run automatically (even if the automatic analysis is checked in the configuration) and needs to be run manually.

Hello Filip,

Thanks for updating this thread. The automatic analysis should indeed trigger if the option is selected, could you have a look at the debug traces to see if something goes wrong?