SonarQube Community License issues

Hi using

  • Community Edition
  • Version 8.4 (build 35506)

i randomly get

{“task”:{“id”:“AXNtFok-1PrnTUdgV9fu”,“type”:“REPORT”,“componentId”:“AXNYKA691PrnTUdgV9a7”,“componentKey”:“Commons”,“componentName”:“Common”,“componentQualifier”:“TRK”,“status”:“FAILED”,“submittedAt”:“2020-07-20T16:37:40+0000”,“submitterLogin”:“admin”,“startedAt”:“2020-07-20T16:37:41+0000”,“executedAt”:“2020-07-20T16:37:43+0000”,“executionTimeMs”:1627,“logs”:false,“errorMessage”:"Analyses suspended. Please set a valid license for the Edition you installed.",“hasScannerContext”:true,“organization”:“default-organization”,“errorType”:“LICENSING”,“warningCount”:1,“warnings”:}}

is there a call back that forces the free community version to be requesting licencees for the dev or enterprise version ?

Hi @FAzevedo,

can you send us a screenshot of your instance where the installed edition is mentioned?
Have you tried before to upgrade to a Developer or Enterprise edition and then downgrade?
How did you upgrade to 8.4? (if you did it)

Thanks,
Carine

Hi

its a fresh install of your community docker container

i did fix this in it

COPY --chown=sonarqube:sonarqube run.sh sonar.sh ${SONARQUBE_HOME}/bin/

has its incorrect if you try and build it

no have not done any upgrades as this is your latest docker container for the community version that i require to use and not the dev or enterprise version and its a brand new install

it those seams only to happen after a couple of builds and will be back working after the container its restarted

has attached

Hi again,

can you send us a screenshot of your SonarQube including the page footer?
Parallel question: do you have only 1 SonarQube server connected to your DB?

Have a nice evening,
Carine

Hi

yes correct single server connected to a single PostgreSQL database

image with footer as follow

thanks you to

Hi,

Thanks for the full-page screenshot. It does confirm that the instance you’re looking at is indeed Community Edition. At the same time, randomly weird behavior does seem to be a hallmark of having multiple SonarQube instances pointed at the same database. Is it possible you have an older, maybe experimental instance still running that either didn’t get shut down somehow or maybe accidentally started back up?

If you’re sure that’s not the case, it would be helpful to have a full page screenshot - including the page footer - the next time you see this error.

 
Ann

Hi , there is no older instance there never was 1 before this one and there is only 1 Sonarqube container running and tis being started manually inside a ec2 instance

has below screen shot

running docker process

it has then started to work once again by it self

Hi,

Could you show the Error Details of that failed analysis?

 
Ann

Hi

it as above

Hi,

i have now updated to

and the issue its still existent

it comes to my mind do you guys have any call backs in the community apps ? that can be generating the issue ?

Hi,

any updates on this ?

i guess you may need this

Server ID ABFAE0DE-AXMpW0tDuNu2KPri-r3M

thanks

Hi Guys,

i need a reply on this or your community version is free or its not ?

what do you have marked in your system for our server ID has this remains the same since we have been using it

Server ID: ABFAE0DE-AXMpW0tDuNu2KPri-r3M (that its actually a database ID)

has to me looks that each run makes a call to your internal systems and at same point your system its giving a reply back that its incorrect to our community version and then failing the builds

can this issue please be checked ? and solved ?

thanks

Hi,

Community Edition is indeed free, and it will never ask for a license key. That’s why I have to believe something weird is going on in your setup. Wanna provide your list of plugins?

 
Ann

Hi,

its running with the defaults plugins only, no other plugins are installed

thanks

Then I don’t know how to help you.

Hi

this is you app correct ?

so every thing new :slight_smile:
new db
new ec2 instance
new container

here is the server info
sonarqube-support-info-ABFAE0DE-AXOgC4pPjIJ24BcLhJm4-2020-7-30-16-55.json (21.6 KB)

here is the new server (db id)

SonarQube ID information
Server ID: ABFAE0DE-AXOgC4pPjIJ24BcLhJm4
Version: 8.4.1.35646
Date: 2020-07-30

you can see the failed on the list above

they have failed with

if you can give me some light the matter … because community should not have any licence has you guys build different packages for it