Sonarqube analysis fails with error code : 134

We are trying to run sonarqube analysis through github actions and we are getting the below error for all the sonar analysis, can you please help us to understand what could be the issue.

issue is resolved only when we have made changes in the yaml file .

      dotnet tool install --global dotnet-sonarscanner --version 5.6

when we change the sonar scanner version t 5.7 we still get the same error , please advise.

Hey there.

Can you provide the full logs from the failure, rather than just a screenshot?

Same issue for me. 5.6 works. 5.7 fails when we do a “dotnet sonarscanner end”.

We are running this on Github Runner inside a .net sdk 3.1 container (JDK was manually installed)

 steps:
      - name: checkout repository
        uses: actions/checkout@v3
        with:
          fetch-depth: 0

      - name: install sonar global tool
        run: |
          rm -f nuget.config
          dotnet tool install --global dotnet-sonarscanner

      - name: Install JVM
        run: apt-get update && apt-get install -y --no-install-recommends openjdk-11-jre

      - name: test execution and sonar scan
        run: |
            dotnet sonarscanner begin /k:"${{ github.event.repository.name }}" /d:sonar.host.url=${{ secrets.SONAR_HOST_URL }} /d:sonar.login=${{ secrets.SONAR_TOKEN }} /d:sonar.cs.opencover.reportsPaths="$report_paths"


          dotnet restore "${{ inputs.solution }}"  --no-cache --force
          dotnet build "${{ inputs.solution }}"

          for test in "${tests[@]}"
          do
            echo "Running $test"
            bash -s <<<"$test"
          done

            dotnet sonarscanner end /d:sonar.login=${{ secrets.SONAR_TOKEN }}

        shell: bash
SonarScanner for MSBuild 5.7
Using the .NET Core version of the Scanner for MSBuild
Pre-processing started.
Preparing working directories...
10:42:26.928  Updating build integration targets...
10:42:27.232  Fetching analysis configuration settings...
10:42:27.401  Provisioning analyzer assemblies for cs...
10:42:27.403  Installing required Roslyn analyzers...
10:42:27.637  Provisioning analyzer assemblies for vbnet...
10:42:27.637  Installing required Roslyn analyzers...


//Code is compiled and tests executed...

SonarScanner for MSBuild 5.7
Using the .NET Core version of the Scanner for MSBuild
Post-processing started.
Unzipping sonar-scanner-cli-4.7.0.2747.zip
Calling the SonarScanner CLI...
Unhandled exception. System.ComponentModel.Win32Exception (13): Permission denied
   at System.Diagnostics.Process.ForkAndExecProcess(String filename, String[] argv, String[] envp, String cwd, Boolean redirectStdin, Boolean redirectStdout, Boolean redirectStderr, Boolean setCredentials, UInt32 userId, UInt32 groupId, UInt32[] groups, Int32& stdinFd, Int32& stdoutFd, Int32& stderrFd, Boolean usesTerminal, Boolean throwOnNoExec)
   at System.Diagnostics.Process.StartCore(ProcessStartInfo startInfo)
   at System.Diagnostics.Process.Start()
   at SonarScanner.MSBuild.Common.ProcessRunner.Execute(ProcessRunnerArguments runnerArgs)
   at SonarScanner.MSBuild.Shim.SonarScannerWrapper.ExecuteJavaRunner(AnalysisConfig config, IEnumerable`1 userCmdLineArguments, ILogger logger, String exeFileName, String propertiesFileName, IProcessRunner runner)
   at SonarScanner.MSBuild.Shim.SonarScannerWrapper.InternalExecute(AnalysisConfig config, IEnumerable`1 userCmdLineArguments, ILogger logger, String fullPropertiesFilePath)
   at SonarScanner.MSBuild.Shim.SonarScannerWrapper.Execute(AnalysisConfig config, IEnumerable`1 userCmdLineArguments, String propertiesFilePath)
   at SonarScanner.MSBuild.PostProcessor.MSBuildPostProcessor.InvokeSonarScanner(IAnalysisPropertyProvider cmdLineArgs, AnalysisConfig config, String propertiesFilePath)
   at SonarScanner.MSBuild.PostProcessor.MSBuildPostProcessor.Execute(String[] args, AnalysisConfig config, ITeamBuildSettings settings)
   at SonarScanner.MSBuild.BootstrapperClass.PostProcess()
   at SonarScanner.MSBuild.BootstrapperClass.Execute()
   at SonarScanner.MSBuild.Program.Execute(String[] args, ILogger logger)
   at SonarScanner.MSBuild.Program.Execute(String[] args)
   at SonarScanner.MSBuild.Program.Main(String[] args)
   at SonarScanner.MSBuild.Program.<Main>(String[] args)
Error: Process completed with exit code 134.

Hello @AnilVinukonda @raoganeshr

Thank you for your feedback, we apologize for the problem.

@raoganeshr We’ve just published v 5.7.1 of the scanner (reverting the change that we believe it caused the problem). Please let me know if this solves the issue - a simple rerun of the task should pick up the latest 5.7.1.

If not, please revert to 5.6.0 (see here the command with --version 5.6).

Thank you Andrei, I have tried with version 5.7.1 and the sonar analysis is successful.

Same here. 5.7.1 worked for me.

Great! Thanks @AnilVinukonda and @raoganeshr for the confirmation.