Sonarqube 9.3 to 10.3 update

Hello, please help with a case of updating from version 9.3 of sonrqube to 10.3, when changing the folder to the new one, sonarqube crashes and gives an error 500 on the main page. Furthermore, no log is created within the root.

Hi,

Welcome to the community!

This sounds like a permissions problem. Make sure the user account running SonarQube has full permissions, recursive, to the SonarQube directory.

 
HTH,
Ann

Good day, I checked permissions and uploaded for the entire sonarqube folder, but it still keeps error 500 and I don’t see service. I attach detail images that the server gives me

Please your support



permisos carpeta sonar

Hi,

It looks like you’re using the Bitnami image. I suggest you start over with an official one from SonarSource. Just make sure to retain your old database and point your new version to it.

 
HTH,
Ann

Yes, download the image from your formal portal. I also tried installing a server on Amazon with the new version, but the database gives an error, since version 10.3 maintains the columns that version 9.3
I don’t know what to do in this case to maintain the data of users and projects

Hi,

Oops. I overlooked that.

Your upgrade path is:

9.3 → 9.9.3 → 10.3 (last step optional)

You may find these resources helpful:

Then why do I see bitnami in all your screenshots? (BTW, we really don’t like screenshots of logs).

 
Ann

Now if you can do it, I followed the indicated order and it worked. Thank you very much for your support!

2 Likes