Sonarqube-7.5 failed to start

Hi ,

I have freshly installed sonarcube-7.5 in my ubuntu 18.0.4

I just want to start with sudo /bin/sh start

it fails continuously with below log

→ Wrapper Started as Daemon
Launching a JVM…
Wrapper (Version 3.2.3)
Copyright 1999-2006 Tanuki Software, Inc. All Rights Reserved.

2021.07.07 15:49:54 INFO app[o.s.a.AppFileSystem] Cleaning or creating temp directory /home/cicd/cicdtools/sonarqube/sonarqube-7.5/temp
2021.07.07 15:49:54 INFO app[] Elasticsearch listening on /
2021.07.07 15:49:54 INFO app[o.s.a.p.ProcessLauncherImpl] Launch process[[key=‘es’, ipcIndex=1, logFilenamePrefix=es]] from [/home/cicd/cicdtools/sonarqube/sonarqube-7.5/elasticsearch]: /home/cicd/cicdtools/sonarqube/sonarqube-7.5/elasticsearch/bin/elasticsearch -Epath.conf=/home/cicd/cicdtools/sonarqube/sonarqube-7.5/temp/conf/es
2021.07.07 15:49:54 INFO app[o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
2021.07.07 15:49:56 INFO app[o.e.p.PluginsService] no modules loaded
2021.07.07 15:49:56 INFO app[o.e.p.PluginsService] loaded plugin [org.elasticsearch.transport.Netty4Plugin]
2021.07.07 15:49:59 WARN app[o.s.a.p.AbstractProcessMonitor] Process exited with exit value [es]: 1
2021.07.07 15:49:59 INFO app[o.s.a.SchedulerImpl] Process [es] is stopped
2021.07.07 15:49:59 INFO app[o.s.a.SchedulerImpl] SonarQube is stopped
← Wrapper Stopped

I tried to change following settings in my system still no use.

$ sudo sysctl -w vm.max_map_count=262144
$ sudo sysctl -w fs.file-max=65536

Adding below in limits.conf .
sonarqube - nofile 65536
sonarqube - nproc 4096

below is my java version installed.

$ java -version
openjdk version “1.8.0_292”
OpenJDK Runtime Environment (build 1.8.0_292-8u292-b10-0ubuntu1~18.04-b10)
OpenJDK 64-Bit Server VM (build 25.292-b10, mixed mode)

Any leads on this would be highly appreciated.


Hello @rkv and welcome to the community :wave:

SonarQube 7.5 is waaayyyy EOL. if you are starting fresh, please use the current LTS (8.9.1) minimum or our latest release 9.0.
Please note that both of these versions require java 11. you can find more information regarding the requirements in our docs.

regarding your problem. take a look at the log ($SONARQUBE_HOME/logs/) files if there is any additional information in there.

I got this working , with two steps .

  1. Use openjdk-11
  2. export the JAVA_HOME variable


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.