SonarQube 5.6 LTS roadmap / plugin support


I’m using SonarQube 5.6.7 and I’m wondering if it is still supported, as it is marked as LTS. Is there any roadmap of how long LTS versions are supported?

Additionally, I recognized that I can’t install plugins any more. I always get a message like Error while downloading plugin 'xyz' with version 'x.y'. No compatible plugin found. Have all the plugins been migrated to the new 6.7 LTS version or am I facing another problem?


Hi Robert,

There’s only one LTS at a time. When 6.7(.*) was announced as the LTS, 5.6.* immediately stopped being the LTS. As a courtesy, we continued to show 5.6 in the Update Center until about mid-June, but then that was stopped as well.

You really should upgrade to at least 6.7.5 at your earliest convenience.



I am using sonarqube 6.3.1 with the mySql version 5.6 and I am trying to install “FxCop” plugin. But I always get the same message: Error while downloading plugin ‘fxcop’ with version ‘1.4.1’. No compatible plugin found.

I have also tried the sonarqube 6.3.1 with mySQL version 8 and got the same error.

Does all the versions before 6.7 are obsolete, thats why I am having this problem?

This post here looks relevant to my problem, so I post it here or should I make a new post?

Thank you.


Your topic is related, but a new post might have been better. However even if you had created a new thread I would have told you the same thing I’m going to say here: You’re going to have a hard time finding support for any version <6.7.

Specifically tho, this obsoletion is likely the root of your problem. After a certain amount of time goes by, we do clean old SQ versions out of the Update Center/Marketplace. If you really can’t upgrade, and you really want to use this plugin version, manual download and install is always an option.


Hi All,

Sorry, not really understand how the TLS works.
If I am still using the sonarQube version 5.6.3, mean if I need any support, I will not able to get it? Please do advise, thanks!


Yes. That’s what that means. 5.6.* used to be LTS, but in fall 2017 6.7.* became the LTS and support for 5.6.* was dropped.