Sonarlint with VS Code on Mac is not analysing files

Please provide

  • Operating system: MacOS 12.3.1
  • IDE name and flavor/env: VSCode 1.67.2
  • SonarLint plugin version: v3.5.3
  • Is connected mode used: NO
    • Connected to SonarCloud or SonarQube (and which version):

And a thorough description of the problem / question:

I have just installed sonarlint and it doen’t seem to be doing anything.
I have tried deliberately writing non compliant python code using examples straight from the rules. I get nothing. Nothing in the output.

I tried similar for javascript and get the following in the output for every .js file I edit:
[Warn - 16:41:00.848] Illegal state. File ‘file:///Users/nickfreer/Library/CloudStorage/Box-Box/Documents/0%20Work/clistuff/javascript/play.js’ is reported changed but we missed the open notification

Hello, welcome to the community! And thank you for reporting this.

It seems that this issue was also reported on this other thread. May I suggest that you follow the discussion there?

I’m thinking about ways to investigate and/or reproduce the issue, I will probably share additional details later today.

1 Like

For your information, version 3.5.4 just got published to the marketplace, it should fix the issue you describe in your initial post.