SonarLint JavaScript Rules Configuration does not appear to me in Eclipse

Please provide

  • Operating system: Windows 10
  • SonarLint plugin version: 7.8
  • Programming language you’re coding in: JavaScript
    • Connected to SonarCloud or SonarQube (and which version): No

And a thorough description of the problem / question:

I have arrived to a company as a developer, and one of the instructions that I have to follow to configurate Eclipse here is install the SonarLint plugin and activate some Rules Configurations of JavaScript, but In the Rules Configurations, only appearse HTML, Java, PHP, Python, Secrets and XML. I have already tried to, update Eclipse, install the same version that my team has, desinstall and install eclipse and SonarLint and install JavaScript Development Tools, that I read that could solve it, and JavaScript doesn’t appear. Someone could help me? The strange thing here is that even having the same version of Windows, Eclipse and SonarLint than my team JavaScript rules configuration doesn’t appear, it is very frustrating. Thanks.

Hello @DEDED,

There was probably a problem loading the JavaScript analyzer, did you receive any notification ? The most probable cause is that you don’t have the required Node.js version. Please check that all requirements are fulfilled.

If the problem persists, could you enable verbose logs and share them with us ?

1 Like

Thank you!
Installing Node.js the problem was solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.