SonarLint(Eclipse) is not connect to SonarQube Server

Template for a good bug report, formatted with Markdown:

  • Version: Eclipse 2020.06, SonarLint: 5.3.0, SonarQube 8.4.1

  • error observed (wrap logs/code around triple quote ``` for proper formatting)
    SonarLint not connect to SonarQube Server

  • steps to reproduce

  1. Eclipse SonarLint Plugin install
  2. SonarLint binding Setting
    Server URL, account/password input - success
    test connection - success
    connection name input - success
    Finish not worked.
    image

and SonarQube Server log is

 [30/Jul/2020:15:04:14 +0900] "GET /api/developers/search_events?projects=&from= HTTP/1.1" 404 66 "-" "SonarLint Eclipse 5.3.0.19940" "AXOUMZw8KWOlYH7xAD24"
  • potential workaround
    None

P.S.: use the #bug:fault sub-category if you’re hitting a specific crash/error , or the #bug:fp sub-category for rules-related behaviour

Hi @choiks

What make you think something is not working? Can you please be more specific.

The 404 you see in SonarQube logs is expected if you have a community edition of SonarQube, because developer notifications are only available starting from the developer edition.

Yes, I’m using Community Edition 8.4.1.

Doesn’t SonarLint support SonarCube Community Edition?

What is the function of Sonarlint supported by SonarQube Community Edition?

image

It does.

All features of connected mode are available with a community edition of SonarQube, except developer notifications:

  • synchronization of rules
  • synchronization of settings (file exclusions/inclusions, issue exclusions, …)
  • extended rule descriptions
  • suppressing issues marked as false positive or won’t fix on the server

Developer notifications is about sending notifications directly inside IDE when a quality gate status failed.

In Project context menu, “Bind to SonarQube or SonarCloud…”
image

  • SonarLint binding Setting
    Server URL, account/password input - success
    test connection - success
    connection name input - success
    Configuration completed - Fail, Finish not worked
    and no binding.

Finish not worked is
when i clicked “Finish” Button, no screen changed. still Configuration completed screen

and SonarQube log is

10.10.31.193 - - [31/Jul/2020:17:03:22 +0900] "GET /api/system/status HTTP/1.1" 200 76 "-" "SonarLint Eclipse 5.3.0.19940" "AXOUMZw8KWOlYH7xAEZq"
10.10.31.193 - - [31/Jul/2020:17:03:23 +0900] "GET /api/authentication/validate?format=json HTTP/1.1" 200 14 "-" "SonarLint Eclipse 5.3.0.19940" "AXOUMZw8KWOlYH7xAEZr"
10.10.31.193 - - [31/Jul/2020:17:03:50 +0900] "GET /api/developers/search_events?projects=&from= HTTP/1.1" 404 66 "-" "SonarLint Eclipse 5.3.0.19940" "AXOUMZw8KWOlYH7xAEZs"
tsteam@sonarqube-dev:/opt/sonarqube/logs$

Can you please have a look at the SonarLint console, and Eclipse error log, for any relevant message or stacktrace?

Thank you. I find the problem in Eclipse log.

I find the message about Secure storage.

Eclipse Secure Storage use Windows Integration in Eclipse Settings.
I unchecked Windows Integration, then binding is success.

Any idea why Windows Integration is not working? Is it something specific to your setup? From experience this is annoying to have the UI prompt asking for the master password every time you launch Eclipse…

Sorry. I don’t know why.
I think our company recently applied Windows AD(Active Directory), and I think it might be related to it.