Sonarlint-eclipse- issue while running mvn compile in parent pom

Hi Team

I tried to do the eclipse setup for sonarlint-eclipse- in eclipse version 2020-12 (4.18.0). i went through the readme file and ran the mvn compile command in cmd at parent pom but am facing the below error. please help me to rectify.

SonarLint for Eclipse … SUCCESS [ 9.343 s]
[INFO] SonarLint for Eclipse Core … SUCCESS [07:23 min]
[INFO] SonarLint for Eclipse UI … SUCCESS [ 9.846 s]
[INFO] SonarLint for Eclipse CDT … SUCCESS [ 6.315 s]
[INFO] SonarLint for Eclipse JDT … SUCCESS [ 1.034 s]
[INFO] SonarLint for Eclipse m2e integration … SUCCESS [ 0.958 s]
[INFO] SonarLint for Eclipse (feature) … SUCCESS [ 0.325 s]
[INFO] SonarLint for Eclipse (update-site) … FAILURE [ 0.086 s]
[INFO] target-platform for Eclipse 4.17 (2020-09) … SKIPPED
[INFO] SonarLint for Eclipse Core Tests … SKIPPED
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 09:01 min
[INFO] Finished at: 2021-02-22T12:37:43+05:30
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project Could not resolve dependencies for project Could not find artifact org.sonarsource.sonarlint.eclipse:org.sonarlint.eclipse.feature:jar:5.5.2-SNAPSHOT → [Help 1]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR] mvn -rf

Am waiting for the reesponse please help me to resolve this,


Hi @susilsahoo

I don’t think this deserve a new thread, this is still a follow up of Sonarlint-eclipse- issue in eclipse 2019-06

HI Julien

I know u may be busy with multiple works. I can understand and am sorry to disturb. These many days i was struggling cause of this sonarlint eclipse version 5.6 as there were some bug . thats why I tried to download the previous version []. I tried to do the setup. I faced some errors while compiling. anyways i removed all the errors in cmd level and now all module compile is working fine and all are success. but doing the steps as mentioned in readme file still the error are not going in eclipse version 2020-12 (4.18.0). i tried to run compile and package goal in eclipse all builds success. but am not seeing the target-platform-its-e47/
I tried to do the steps with target-platform-2020-06 but still the src and manifest level errors does exist. Please help me to know which version of sonarlint eclipse 5.5 i should use and it should work perfectly fine in what version of eclipse so that i will not get the src and manifest level error. Thanks a lot for ur response to previous message


This topic was automatically closed after 7 hours. New replies are no longer allowed.