Sonarcloud quality gate failure even though coverage more than 88%

We are seeing discripancy in sonarcloud report. Even though Coverage is more than 80% which is more than the threshold(65%) we are seeing quality gate failure. This is happening across all the component builds

Need immediate help in fixing this

I got the same issue but in the SonarCloud. Seems there is a problem with the UI

Same is happening to me:

Is someone of SonarCloud support center that could give us some answer or support?

Hi Siba

Thanks for the report.
We have identified this issue and we will fix it ASAP. This issue is only visual and is not affecting the Quality Gate.

Will let you know once the issue is being fixed.

It appears the issue also affects Coverage and Duplications, see screenshot. This is on SonarCloud (not SonarQube).

Hello,

it fails in every project (overall code)

also it happens with duplication:

image

Template for a good new topic, formatted with Markdown:

  • ALM used: Azure DevOps
  • CI system used: Azure DevOps
  • Scanner command used when applicable: SonarCloudPrepare@1

Also it happens with duplications:

image

Hi there
For an ios project with Swift code, the code coverage and duplication conditions are failing despite being under threshold.

Following is my quality gate:
New Code:


Overall Code:

Thanks in advance.

@ganncamp
Can you please help here?
Thanks

Hi all

This as been fixed on production

Thanks

3 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.