SonarCloud Problem with URL

Hello, recently they took away the internet access on the server where our azure agent is located and that has the sonarcloud task implemented.

So it had to be asked to add to the whitelist

They already added it but whenever I browse it shows me the same error, we use windows server 2016

The funny thing is that if I can telnet to sonarcloud.io 443 and if it responds and right in the browser instead of putting the previous URL we put this (https://www.sonarcloud.io/)

Now my problem, that my task in azure devops always calls http://sonarcloud.io/, is there a way to change that and redirect to https://www.sonarcloud.io/? thanks.

Hello @MartinMaldonado!

Looks like you have an issue with your network configuration, since the “Web Page Blocked” is a response not provided by SonarCloud. The https://www.sonarcloud.io URL is just an alias to allow redirection into the correct address (https://sonarcloud.io). You must use this address for SonarCloud network interactions, so you must fix the network allowance. I hope that helps!

1 Like

Hi Alexandre, of course, what happens in theory is that the network team has already enabled me the whitelist, and they did not give me more alternatives, and I wanted to find a way to be able to perhaps modify a file in the sonarcloud task that allows me to change the url , is that possible???

@MartinMaldonado, unfortunately this feature is not supported in Azure integration.