Sonarcloud not reachable from Azure DevOps

I have been trying to access for last an hour but no luck. I have tried from 3-4 different networks and all the same.

We are having the same problem in the “Prepare SonarCloud” step of our build.

##[error]18:08:18.371  Failed to request and parse 'https://sonarcloud.io/api/server/version': The remote name could not be resolved: 'sonarcloud.io'

https://developercommunity.visualstudio.com/content/problem/822617/sonarcloud-integration-failed.html

1 Like

Experiencing the same problem as well. Glad I’m not the only one.

Upvoted, thanks for the link. Definitely an issue for us as well.

I suspect this is an issue at Azure Devops side. Please follow the link shared by Alain Vezina above and vote and comment on the issue over there.

I dont use Azure Devops, however its an azure VM, could be the same as Azure DevOps uses Azure hosted agent.

it still an issue for me!

Hi,

We are looking closely to that issue, we’ll let you know.

Thanks.

Mickaël

Hi @Alain_Vezina and all, what Azure Geography are your running from? We were able to run from West Europe for example.

Hi there. We have investigated the issue you are facing without being able to reproduce it.

On SonarCloud, we witness a normal workload pattern coming from the Azure DevOps CI, hence we know the Azure DevOps integration is functional for most users.

Based on your feedback, we conclude there are probably DNS issues on the Azure infrastructure, particularly on the Windows OS platform (we’ve seen feedback about Linux agents not being impacted, e.g. here).

If you are impacted by this issue, we recommend you raise your issue with the Azure support, providing them with details about your network context (e.g. geography, IPs, etc…).

1 Like

Thanks

It’s seems to work now.

https://developercommunity.visualstudio.com/content/problem/822617/sonarcloud-integration-failed.html?childToView=824713#comment-824713