SonarCloud moving analysis to java11

Moving to java11 is not as simple as it is stated here. A lot of are things breaking once we upgraded to java11.
Gradle needs to be upgraded to 5.0 to support java11. We are using lombok as an annotation processor for all our projects and older versions of lombok is broken for java11. If lombok is upgraded to newer version then lot of code files need to be changed.

Hello,

You should not have to migrate your full project to Java 11, it’s “only” required that the sonar-scanner runs on Java 11 environment.

Did you try the following trick described in the documentation page you shared:

If you build is not compatible with Java 11, then you still have the possibility to override JAVA_HOME environment variable before running Scanners.