Sonar server is not coming up

  • which versions I am using (SonarQube, Scanner, Plugin, and any relevant extension)
    SonarQube - 5.6.6
    SonarScanner - 2.8
  • what am I trying to achieve
    Starting up the sonar server
  • what I have tried so far to achieve this
    Confirmed database is up and running and with the error throne at the time of execution of StartSonar.bat tried to debut with the help of google but no luck.
    Also when I comment out the “sonar.jdbc.url=jdbc:postgresql://localhost/sonar” line in file it is getting started but no data on dashboard because no database.

Problem facing - When I start startSonar.bat wrapper is starting up and after few minutes wrapper is getting stopped due to the following error in attachments.
Attaching the sonar.log and execution of startsonar.bat here, any leads on this issue.?

sonar.log.txt (16.5 KB) startSonarbatchExecutionLog.txt (3.0 KB)


How long has your instance been down? 5.6.6 is quite old an no longer supported for some time now. Your error log indicates a problem at the database level:

Error updating database. Cause: org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint "ce_activity_uuid"

Do you have any idea how your DB got into this bad state?


P.S. The server starts up when you remove the DB configuration because’s it’s falling back to the embedded, demo database.