Sonar.properties not being reflected on OCP

I am attempting to deploy a customized version of SonarQube (8.3) on OpenShift (3.11) using this Helm Chart.

The chart correctly initializes the container (downloads and installs plugins and populated the conf/sonar.properties file, however, the properties set are not being reflected. Is there a command that I need to run to make the changes stick?

I tested this with. SMTP settings and the server did not pick them up. These are core settings in SQ, and there are a lot of settings that I need to set for plugins such as the OpenShift authentication plugin.

Hi,

Unless the properties were listed in sonar.properties originally, they’re not going to work for you. There are properties that are set via that config file and properties that are set via the UI. There aren’t (supposed to be - we’ve made a couple mistakes along the way) properties that can be successfully set in both places.

 
HTH,
Ann

Thanks for the response!

I do not want to change the configuration settings in the UI, rather I want to “spin” up an instance of SonarQube that is already customized with plugins and settings. The aforementioned Helm Chart successfully downloads and installs plugins, and writes properties to $SONARQUBE_HOME/conf/sonar.properties

This is a sample of what the sonar.properties file looks like:

sonar.auth.github.allowUsersToSignUp=false
sonar.log.console=true