SAML and baseURL settings set via sonar.properties are not displayed in UI

I’ve set the following in sonar.properties …

sonar.jdbc.removeAbandoned=true
sonar.jdbc.removeAbandonedTimeout=30
sonar.core.serverBaseURL=https://sonarqube.{hostname} sonar.forceAuthentication=true sonar.auth.saml.enabled=true sonar.auth.saml.applicationId=sonarqube sonar.auth.saml.providerName=SAML sonar.auth.saml.providerId={sso_providerid}
sonar.auth.saml.certificate.secured={sso_cert} sonar.auth.saml.loginUrl={sso_login_url}
sonar.auth.saml.user.login=name
sonar.auth.saml.user.name=dn
sonar.auth.saml.user.email=email

The config works and SSO logging is working as expected. The issue is the non of the values appear in the web ui.

Using Version 6.7.5.38563

Hi @burdena,

Such settings should not be set in sonar.properties, you should set them using the UI or WS.

Regards,
Julien Lancelot

Cheers for the reply.

Are you saying only values listed in https://github.com/SonarSource/sonarqube/blob/master/sonar-application/src/main/assembly/conf/sonar.properties are supported ?

Seems strange that the app will read them from the file and use them but not display them on the UI. Should that be considered a bug ? I also believe the values in the file override the ui settings, which can cause confusion, I’ll test later.

Yes, and we’ll enforce this by this ticket : https://jira.sonarsource.com/browse/SONAR-11818

1 Like

This seems to me a step backwards. Can you not have sonarqube read an extra properties file where other settings can be serialised?

Doing this via API calls is extra effort for the helm chart. I’ll do a PR to update the documentation because I am sure others will be trying to add properties to sonar.properties configure sonarqube and plugins.

1 Like