Sonar process is being killed automatically


(Priyanka Sharma) #1

Hi,
I was using sonarqube 7.2 version.It was running properly on port 8443 but accidentally the whole sonarqube-7.2 folder got deleted and then I was not able to stop it as there was no sonar.sh available.I did netstat -tnlp , process was still running on port 8443 then I killed the process forcefully.
Now when I have downloaded a different version and tried to install it … It is not running,its being killed automatically with errors:

max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

I have done all systems settings according to this error still its coming.
Can anyone help with this ASAP with highest priority.???


(G Ann Campbell) #2

Hi,

The docs describe how to set vm.max_map_count system-wide: https://docs.sonarqube.org/display/SONAR/Requirements#Requirements-Linux

HTH,
Ann


(Priyanka Sharma) #3

I have set these values already.Still throwing the errors.


(Janos Gyerik) #4

The previously posted message showed that “[65530] is too low, increase to at least [262144]”. Do you get a new message with new recommended increase, or do you get different errors? (if yes, what are they?)


(Priyanka Sharma) #5

Hey,
I have not increased any values as they were set with the desired values.
But problem has been resolved and the cause was different.Thanks all for you response. :slight_smile:


(Nicolas Bontoux) #6

It would be interesting that you share what the actual problem was, and how you solved it, so that other members of this community can benefit from your findings in case they encounter similar problems!


(Priyanka Sharma) #7

Sure.
I needed upgraded vb.net-5.5 plugin for sonarqube-6.7.4 version so I have downloaded that but i was unaware that it comes with a licence so when I started the sonar service It was looking for the licence for the same and when it was not available then it threw the error.
I have checked my logs in ce.log file and I have found the error. After removing that plugin from my SONAR_HOME/extensions/plugins directory, it resolved my problem.
Thanks all.


(Nicolas Bontoux) #8

Thanks for the clarification, which means that it relates to this thread below:

Make sure to share related threads so that it’s easier for people to follow the reasoning/solution. Given that this is solved I’ll close this specific topic here.


(Nicolas Bontoux) #9