Sonar data center installation


I want to install sonar datacenter on CENTOS.
I have probleme to install searchNode.

How i start search node ? with the ? or the file under exlasticsearch dir ?


I have this error in es.log :

2020.06.16 11:52:01 ERROR es[o.e.b.Bootstrap] node validation exception
[2] bootstrap checks failed

Hi @davidBpce ,

welcome to the community (:
you can start the node with the script with the start parameter. SQ will read in which variant (search or application) it should run from the file, but it seems that you have already found this out.

i can not see the full error message but i guess the


is too low. can you check back if your system complies to the specifications here ?



it was that :slight_smile:

But now i have an error to join the eslasticsearch master

2020.06.16 13:22:11 INFO es[o.e.d.z.ZenDiscovery] failed to send join request to master [{sonarqube-f9cd8539-e03a-4b2a-8501-b4647cdf09b2}{er1-nu5ESRmJJVIpXXUO2w}{ZanRJ0wpT86xfKDB7laKRQ}{xxx}{xxx:9001}{rack_id=sonarqube-f9cd8539-e03a-4b2a-8501-b4647cdf09b2}], reason [RemoteTransportException[[sonarqube-f9cd8539-e03a-4b2a-8501-b4647cdf09b2][][internal:discovery/zen/join]]; nested: NotMasterException[Node [{sonarqube-f9cd8539-e03a-4b2a-8501-b4647cdf09b2}{er1-nu5ESRmJJVIpXXUO2w}{ZanRJ0wpT86xfKDB7laKRQ}{xxx{xxx:9001}{rack_id=sonarqube-f9cd8539-e03a-4b2a-8501-b4647cdf09b2}] not master for join request]; ], tried [3] times

This looks like a network issue. on centos it could be firewalld that is blocking the communication between the elasticsearch nodes.
you need to ensure communication on port 9001/TCP 9200/TCP and 9300/TCP in between all search nodes

miss some configuration,

its works now

Glad it’s working for you now (:
Have a good day