Sonalint - Invalid binding issue because of 'component_list.pb'

environments information

  • macOS Big Sur (11.6.1)
  • IDE: IntelliJ (2020.03, 2022.01)
  • sonarlint plugin version: 6.7.0.45926
  • sonarqube version: 9.5.0.56709
  • JDK version: openjdk 11.0.2 2019-01-15

Hi,

I’m facing following issue when I try to use sonalint connecting sonarqube with IntelliJ IDE.

because of this, ‘Analysis with Sonalint’ is not working.

Sonalint - Invalid binding
Project bound to an invalid remote project 
Please check the SonarLint project configuration

So when I try to modify configuration and click ‘Update binding button’
error pops up with message below.

Binding Update Failed

Failed to read file: /Users/{myid}/Library/Application Support/JetBrains/IdeaIC2022.1/sonarlint/storage/736f6e61727465737432/projects/736f6e61727465737432/component_list.pb

I look directory /Users/{myid}/Library/Application Support/JetBrains/IdeaIC2022.1/sonarlint/storage/736f6e61727465737432/projects/736f6e61727465737432/

but there is not ‘component_list.pb’ file.
only two files are exist - analyzer_config.pb project_branches.pb

What’s component_list.pb ? How can I get that file? or is that something like version conflict?

Please help. thanks.

1 Like

WHere you able to find the solution.I am facing same issue.

Hi, sorry for the late answer.

We are currently rewriting the connected mode local storage in SonarLint, so hopefully, that kind of error should disappear in a near future.
In the meantime, you can manually trigger an update of the local storage. Go to IDE settings, SonarLint, select your connection, and click “Update binding”:

Hey Julien,

How to manually trigger update of the local storage? When I clicked “Update Binding” I still get same error.

Hi, what error do you get exactly? Can you look at the SonarLint log panel, and copy/paste any error you can see?

image
Same issue here:

Hi. Having the exact same issue on Windows connected to SQ Enterprise.

Update: The problem was resolved when I generated a User Token to authenticate sonarlint vs a Project Token used previously

1 Like

Good catch! Maybe this is something we could detect from SonarLint to give a better error message. I have created a ticket:
https://sonarsource.atlassian.net/browse/SLI-753