[SOLVED]Project not found for a new project

Hi,

I’ve been trying to configure a Sonar project, but unfortunately the initial scan keeps failing with:

ERROR: Project not found. Please check the ‘sonar.projectKey’ and ‘sonar.organization’ properties, the ‘SONAR_TOKEN’ environment variable, or contact the project administrator

The weird thing is that the project is tiny and I just copy/pasted all the commands from the configuration screen (not doing anything crazy). I also tried different methods (GH actions, locally with Gradle, locally with SonarScanner, but no luck). Could someone have a look and let me know what I am doing wrong ? Obviously I set up the SONAR_TOKEN env variable.

Locally I am running

sonar-scanner
-Dsonar.organization=firebolt-db
-Dsonar.projectKey=firebolt-db_sisense-firebolt-driver
-Dsonar.sources=.
-Dsonar.host.url=https://sonarcloud.io

and the project is GitHub - firebolt-db/sisense-firebolt-driver at feature/enable-sonarcloud.
Could it be because I’m trying to run the analysis on a custom branch ? Should still work with the sonar-scanner locally though ?
Thanks !

The issue is solved - it was actually a permission issue :relieved:.

1 Like

Hi Aymeric,

I’m running into the same issue as you are.
Analysis seems to be running but getting a "ERROR: Project not found. " at the very end.
Could you elaborate which permissions were causing the problem?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.