(Solved) ERROR: SonarQube server [https://my-domain.com] can not be reached

Hi there, I am trying to host an internal SonarQube application on an AWS EC2 instance. So far, I have configured the server, it is up and running. Then, I added a security group to limit the access to only VPN and assigned a certificate to it for the HTTPS connection.
At this point, SonarQube cannot scan upon new commits. I have tried adding a simple workflow to add the GitHub Actions address to the security group, but it didn’t fix the issue. The error I am getting is as follows:
ERROR: SonarQube server [https://my-domain.com] can not be reached

I can share future details if necessary.
Thanks in advance!


“Failed to get bootstrap index from server” means that the sonar.host.url value provided to analysis isn’t reachable. You’re going to need to figure out how to make your secured server visible to analysis.


Hello, thank you for answering.
The secured server was reachable when I first added the projects to Sonar. I set up the “Sonar Host URL” on GitHub as SonarQube described (actual public URL) and it worked with no issues. I did not make changes to the server and/or GitHub secrets except for a script to temporarily add GitHub actions IPs to the EC2 security group.
Could there be another issue causing new commits to be failed to scan?

Hi again,
The issue was that the IP added to the security group did not include the necessary port for connection. I updated the workflow to temporarily open all ports for the specific GitHub actions IP and that solved the issue.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.