SAML configuration will not save

ZIP deployment

I am attempting to create a SAML auth profile. I am following the instructions found here:

Setup on the Azure side is complete. When filling out the form in SonarQube, even though I’ve entered valid information in all of the fields, for many of them it tells me “This field cannot be saved. Try again later.” and does not allow me to save.

I was using a plug in previously for AAD authentication, which has since been removed from the extensions directory and SonarQube restarted. Logging in with the local admin user to make these changes.

Any idea what is going on?


Welcome to the community!

Do you have any errors in your browser console? In your server logs?


Nothing that seems to be related in any of the server logs, or in the debug console on the browser.

I have tried re enabling the old Azure AD plugin and removing all of the settings, putting it back to default. Then removing that plugin again just in case it was having issues with already existing settings. Still the same result.

Screen shot of the error

To make things a bit more interesting, if I put some basic text in those fields just to test with it saves the info just fine. When I put the actual values back in there that should be there, we are back to the original error.

After messing around more with it, this began to make sense.

Any time I would include a URL in the fields with “://” in there, it kicked it back. Plain text was OK.

We have this published behind and Azure App Gateway with a WAF enabled. Sure enough, the WAF did not like those values. Accessing it locally from the server itself and skipping the WAF allowed me to save the settings fine. The solution here is going to be adding some custom WAF rules. Just in case anyone else runs into this in the future!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.