Run Code Analysis Azure Devops Step Fails

Infrastructure information:
SonarQube Azure Devops Plugin version: 4.17.0
SonarQube Server Community Edition version: 8.5

Due to the updates that we have done in the SonarQube Azure Devops Plugin on our Azure Devops portal, we decided to move into upgrading our SonarQube Server installation to the latest version. We have concluded the upgrade but the following issue has been breaking pipeline builds on the Run Code Analysis step:

I can’t figure out what the issue is and but I suspected that the update might have removed some pre-existing configuration that we had so I tried to install the plugin SonarQube SCM TFVC in the SonarQube Server Marketplace since I thought that this error is due to Code Analysis not supporting tfs but only git and svn by default. I did so and after running the build again Code Analysis worked but it completely ignored all suppressions that have been previously implemented and assigned all issues to me.

Any guidance on the issue or the structure of this post itself would be greatly appreciated.

Indeed, the error makes sense if you had the TFVC plugin installed before, and did not afterwards. Reinstalling it makes sense.

Can you be a bit more detailed here? How did you implement these suppressions (in-code, marking issues as false-positive/won’t fix, pattern matching)?


These suppression were implemented via SonarLint and are mostly contained within .cs suppression files inside the different projects that exist in our main solution. Some of the suppressions were implemented via the Web Portal for newer issues that have been found. Since our solution is complex with hundreds of projects it is difficult to use SonarLint so I have been using the web portal to suppress newer issues.

I have realised that necessary plugins such as C# Code Quality and Security are not available on SonarQube Server version 8.5 so I think the best choice here is to perform a rollback to version 8.4 and include all plugins that were installed to in the older version.