Rule is not shown in VS Code with SonarLint

Hi,

we are using SonarQube Version Version 7.4 (build 18908). In one Quality Profile, we have an active rule javascript:S1940 and this code smell is shown in a file breaking this rule. Until this point, everything seems as it should be.

Now, when opening in Visual Studio Code this file with SonarLint, this code smell is not shown there. But I get an error message like this one:

INFO: EXECUTION FAILURE
INFO: ------------------------------------------------------------------------
INFO: Total time: 54.792s
INFO: Final Memory: 5M/78MERROR: Error executing SonarLint
INFO: ------------------------------------------------------------------------

org.sonar.squidbridge.api.AnalysisException: Unable to analyse file: c:/path/to/project/and/some/file.js
	at org.sonar.plugins.javascript.JavaScriptSquidSensor.analyse(JavaScriptSquidSensor.java:175)
	at org.sonar.plugins.javascript.JavaScriptSquidSensor.analyseFiles(JavaScriptSquidSensor.java:134)
	at org.sonar.plugins.javascript.JavaScriptSquidSensor.execute(JavaScriptSquidSensor.java:343)
	at org.sonarsource.sonarlint.core.analyzer.sensor.NewSensorsExecutor.executeSensor(NewSensorsExecutor.java:72)
	at org.sonarsource.sonarlint.core.analyzer.sensor.NewSensorsExecutor.execute(NewSensorsExecutor.java:63)
	at org.sonarsource.sonarlint.core.analyzer.sensor.PhaseExecutor.execute(PhaseExecutor.java:36)
	at org.sonarsource.sonarlint.core.container.analysis.AnalysisContainer.doAfterStart(AnalysisContainer.java:141)
	at org.sonarsource.sonarlint.core.container.ComponentContainer.startComponents(ComponentContainer.java:125)
	at org.sonarsource.sonarlint.core.container.ComponentContainer.execute(ComponentContainer.java:110)
	at org.sonarsource.sonarlint.core.container.standalone.StandaloneGlobalContainer.analyze(StandaloneGlobalContainer.java:144)
	at org.sonarsource.sonarlint.core.StandaloneSonarLintEngineImpl.analyze(StandaloneSonarLintEngineImpl.java:93)
	at org.sonarlint.cli.analysis.StandaloneSonarLint.doAnalysis(StandaloneSonarLint.java:53)
	at org.sonarlint.cli.analysis.SonarLint.runAnalysis(SonarLint.java:59)
	at org.sonarlint.cli.Main.runOnce(Main.java:118)
	at org.sonarlint.cli.Main.run(Main.java:97)
	at org.sonarlint.cli.Main.execute(Main.java:188)
	at org.sonarlint.cli.Main.main(Main.java:148)
Caused by: java.lang.NullPointerException
	at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:212)
	at com.google.common.io.ByteSource$AsCharSource.<init>(ByteSource.java:443)
	at com.google.common.io.ByteSource$AsCharSource.<init>(ByteSource.java:438)
	at com.google.common.io.ByteSource.asCharSource(ByteSource.java:74)
	at com.google.common.io.Files.asCharSource(Files.java:226)
	at com.google.common.io.Files.toString(Files.java:274)
	at com.sonar.sslr.api.typed.ActionParser.parse(ActionParser.java:91)
	at org.sonar.javascript.parser.JavaScriptParser.parse(JavaScriptParser.java:43)
	at org.sonar.javascript.parser.JavaScriptParser.parse(JavaScriptParser.java:29)
	at org.sonar.plugins.javascript.JavaScriptSquidSensor.analyse(JavaScriptSquidSensor.java:163)
	... 16 more

Visual Studio Code About gives me this information

Version: 1.35.1 (system setup)
Commit: c7d83e57cd18f18026a8162d042843bda1bcf21f
Date: 2019-06-12T14:30:02.622Z
Electron: 3.1.8
Chrome: 66.0.3359.181
Node.js: 10.2.0
V8: 6.6.346.32
OS: Windows_NT x64 10.0.17134

SonarLint Version is 1.8.0 (is there an easy way to check that?). SonarLint is in connected mode, i.e. I added to the User settings (C:\Users<myuser>\AppData\Roaming\Code\User\settings.json) these settings:

{
    "sonarlint.connectedMode.servers": [
        {
          "serverId": "SOMEID",
          "serverUrl": "http://sonarqubeserver:9000",
          "token": "somenicetoken"
        }
      ]
}