Ruby plugin should consider ruby version 2.6

Hi, after running latest rubocop including I got syntax errors reported by sonarqube for the endless ranges (1…) introduced in ruby 2.6

After digging a bit deeper, I found that requires the parser for ruby 2.5, that does not support the endless ranges.

This limits the usefulness of sonarqube, if one wants to use new syntax introduced by newer ruby versions. Rubocop itself uses the ruby version defined in .ruby-version file, could that be an option to use the corresponding parser?

Hello @Aqualon,

thanks for reporting this issue, I created ticket in JIRA , but I can’t provide any eta when this will get fixed (I hope we would be able to refresh Ruby plugin within next few months)

Hello @saberduck :wave:
I see that the ticket marked as closed. Do you know in what SonarQube version I can found these changes?

Hello @DaniilLeksin,

The support of Ruby 2.7 is available from SonarQube 8.6.

By the way, SonarQube 8.7 will introduce the support of Ruby 3.0.


1 Like

Thanks a million @Quentin :bowing_man:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.