Process exited wth exit value [es]: 143 error

Hi Team

I have setup and end up with getting error 143 after all been checked and configure and please assist me to resolve the issues

My env details are:

  1. Linux RedHat 7.5
  2. Sonarqube 7.9 community Edition
  3. Postgresql 9.4 or default H2 Database ( also Sevice is not starting )
    4.Crowd integration

Extracted the sonarqube7.9 and while starting with sh console and its not starting and getting the error 143. Unable to fix this issue and kindly assist me


Welcome to the community !

It looks like an elasticsearch-related issue, please go through the troubleshooting page and have a look at the es.log file, it may contain an understandable error message that can help.

Hi Pierre

I did go through troubleshooting and i have deleted es6 and all its not worked and still getting 143. anymore inputs… highly appreaciated


Please provide the full logs that you got

sure, i will share the logs shortly

consolelogs.txt (1.9 KB) web1565871434130.txt (109.1 KB) sonar.txt (147.7 KB) es.txt (43.3 KB)

Pls assist me

your es.log file says :

2019.08.15 07:57:00 ERROR es[][o.e.b.Bootstrap] node validation exception
[1] bootstrap checks failed
[1]: max number of threads [2048] for user [sonar] is too low, increase to at least [4096]

You need to increase this limit. Please have a look at the requirements here :

On the plateform notes, ensure that the user running SonarQube can open at least 4096 threads

I have set the limit 4096 and still getting 143 error and i will be attaching the latest logs file in a while


Pls find the updated logs …es.txt (55.2 KB) Sonar.txt (157.5 KB) Web.txt (143.1 KB)


I ve set that and still i am getting 143 error. When look that these logs…

  1. es.log —> INFO [es] [o.e.n. Node] Started
    INFO [es] [o.e.n.GatewayService] recovered [0] indices into cluster_state
    INFO [es] [o.e.n. Node] Stopping
    INFO [es] [o.e.n. Node] Stopped
    INFO [es] [o.e.n. Node] Closing
    INFO [es] [o.e.n. Node] Closed.
  2. Sonar.log -->
    INFO apa [o.s.a. SchedulerImpl] process [web] is stopped
    WARN apa [o.s.a. AbstractMangedProcess] Process exited with exit value [es]: 143
    INFO apa [o.s.a. SchedulerImpl] process [es] is stopped
    INFO apa [o.s.a. SchedulerImpl] Sonarqube is stopped
  3. web.log -->

INFO we [o.s.s.a.EmbeddedTomcat] HTTP Connector enabled on port 9000
INFO we [o.s.s.a.EmbeddedTomcat] Hard stopping process

Would you mind to have a short call, so that i can call you and running out this and unable to fix this

please the lastest logs and assist me pls


Hi Prasanna,

If your logs say the user running the process doesn’t have access to enough threads then that’s what the problem is. So at this point it’s a Linux question. I know from personal experience that getting these values properly set can be trickier than it should be, but I’m not sure we can help you in this matter beyond identifying what you need to work on.


thank you for your information,lemme revisit and keep this thread updated

Hi Prasanna.

Did you resolve the issues? May i know how to solved it? I get the same error

Hi I am getting same error. Did you find a solution.Please help