Sonarqube community version sonarqube-7.9.2 , Process exited with exit value [es]: 143

I am using sonarqube and when I run the sonar.sh file I get this error “Process exited with exit value [es]: 143”

Issue:-

jvm 1    | 2022.06.25 11:34:41 INFO  app[][o.s.a.AppFileSystem] Cleaning or creating temp directory /apps01/sonarqube-7.9.2/temp
jvm 1    | 2022.06.25 11:34:41 INFO  app[][o.s.a.es.EsSettings] Elasticsearch listening on /127.0.0.1:9001
jvm 1    | 2022.06.25 11:34:41 INFO  app[][o.s.a.ProcessLauncherImpl] Launch process[[key='es', ipcIndex=1, logFilenamePrefix=es]] from [/apps01/sonarqube-7.9.2/elasticsearch]: /apps01/sonarqube-7.9.2/elasticsearch/bin/elasticsearch
jvm 1    | 2022.06.25 11:34:41 INFO  app[][o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
jvm 1    | OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
jvm 1    | 2022.06.25 11:34:42 INFO  app[][o.e.p.PluginsService] no modules loaded
jvm 1    | 2022.06.25 11:34:42 INFO  app[][o.e.p.PluginsService] loaded plugin [org.elasticsearch.transport.Netty4Plugin]
jvm 1    | 2022.06.25 11:35:03 INFO  app[][o.s.a.SchedulerImpl] Process[es] is up
jvm 1    | 2022.06.25 11:35:03 INFO  app[][o.s.a.ProcessLauncherImpl] Launch process[[key='web', ipcIndex=2, logFilenamePrefix=web]] from [/apps01/sonarqube-7.9.2]: /usr/lib/jvm/java-11-openjdk-11.0.15.0.9-2.el7_9.x86_64/bin/java -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djava.io.tmpdir=/apps01/sonarqube-7.9.2/temp --add-opens=java.base/java.util=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/java.io=ALL-UNNAMED --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED -Xmx512m -Xms128m -XX:+HeapDumpOnOutOfMemoryError -Dhttp.nonProxyHosts=localhost|127.*|[::1] -cp ./lib/common/*:/apps01/sonarqube-7.9.2/lib/jdbc/mssql/mssql-jdbc-7.2.2.jre11.jar org.sonar.server.app.WebServer /apps01/sonarqube-7.9.2/temp/sq-process17370630629988744481properties
jvm 1    | 2022.06.25 11:35:20 INFO  app[][o.s.a.SchedulerImpl] Process[web] is stopped
jvm 1    | 2022.06.25 11:35:21 WARN  app[][o.s.a.p.AbstractManagedProcess] Process exited with exit value [es]: 143
jvm 1    | 2022.06.25 11:35:21 INFO  app[][o.s.a.SchedulerImpl] Process[es] is stopped
jvm 1    | 2022.06.25 11:35:21 INFO  app[][o.s.a.SchedulerImpl] SonarQube is stopped

Hi @abinashb and welcome to the community :wave:

The sonarqube version you are using is eol and you should update to the current lts version (8.9) or the latest version (9.5 I think).
Apart from that you can check the content of your logs folder in the sonarqube installation directory. There should be a es.log file with more information about the issue. I would guess that the system is currently not supporting the requirements as stated here: Prerequisites and Overview | SonarQube Docs

Hope that helps (:

And, to complement Toby’s answer

Since this was the first log message thrown, I would take a look at your /logs/web.log file.

https://docs.sonarqube.org/8.9/setup/troubleshooting/

Admittedly, as much as we want folks to upgrade, it is hard to upgrade if you can’t get your SonarQube server started. :laughing: