Problem with the sonar swift

I Do have Developer edition of sonarqube but i am not able to get sonarswift in developer edition it is showing u need to have commerical access

I have developer edition too and I also not able to use sonarswift.
It showed:


Which version of SonarQube Developer Edition are you using?
I strongly suggest to use the 7.7 or the upcoming 7.8 (next week).

Can you describe how you run your installation? Did you manually install the SonarSwift plugin in your SonarQube instance?


Hi Alexandre,
Thanks for your swift response.
Version is
Regarding to installation, didn’t it just from Web UI: Marketplace -> Plugin -> Install button?


Could I have a screenshot of your SonarQube footer? It includes the edition you’re running. I ask because Swift is pre-intalled in Developer Edition, so you shouldn’t be seeing what’s shown in your previous screenshot.


Hi Ann,



Thanks for the screenshot. It confirms your earlier statements. (Yes, I know you already knew you were telling the truth :smile: but I’ve learned the hard way to verify the basics. :wink:)

So now let’s back up. You should have Swift installed by default. But you don’t. I have two guesses: either someone manually uninstalled the analyzer at the file system level or somehow your distribution got messed up.

So let’s bypass both options. Please try re-downloading, the bundle, re-expanding it, re-configuring your DB settings in $SONARQUBE_HOME/conf/ After shutting down your current instance spin this new one up and see if it doesn’t contain SonarSwift.