PR decoration no longer working DE 9.6.1


we recently upgraded our SonarQube DE from 8.9.3 → 9.6.1 .
We noticed that since the upgrade, we don’t see any Pull Request Decorations anymore in our Bitbucket Server PR (v7.21.0). Also the link in Sonar to the PRs in Bitbucket are no longer appearing. On analyzed branches before the upgrade, the links are still there.

We did not change any configuration and all settings are still correct. We tried reconfiguring with no success.
When doing a TRACE, there are also no logs appearing that seems related to triggering a pull request decoration (in the ce.log).

Command we run:
sonar-scanner -Dsonar.projectVersion=24cc659 -Dsonar.pullrequest.branch=<branchName> -Dsonar.pullrequest.key=5 -Dsonar.pullrequest.base=master -Dsonar.projectName=<projectName> -Dsonar.projectKey=<PROJECT>:<SLUG> -Dsonar.exclusions=*,app/**,bin/**,var/**,vendor/**,build/**,**/*.spec.ts

Any ideas where to look?


Welcome to the community!

You said you turned on trace logging. Was that in the analysis or at the server? PR decoration happens after the analysis report is submitted to the server, so you wouldn’t see anything relevant on the analysis side.

Can you check your server logs? Hopefully you’ll see something relevant.

It may also be worth re-verifying your connection via the UI: Administration → DevOps Platform Integrations → Bitbucket → Check configuration.

And finally, is it possible the timing is coincidental, and your Bitbucket auth token has expired?


Hi Ann,
the logging was at the server. There was nothing relevant that I could quickly find.
The configuration works, when we do a “Check Configuration” it is valid (and as such, the auth token is also not expired).

Not sure if it is possible to downgrade to a previous version (are there any database changes between 9.x and 9.6.1)?

Hi @rhasp,

PR decoration should work properly for each version that we released. It’s not a good idea to downgrade because of this issue.

I’m happy to help you further on this. But I need more information. Could you set up your server logs to debug and share the server logs along with analysis debug logs?

I will send you a PM so that you can share the logs with me.

I have double checked everything so far. The token is working fine, but I recreated new one just to be sure. There is nothing relevant as far as I can see in the logs (both server and analysis)

Hey Rolph,

We had the exact same problem – we upgraded from 8.9.8 to 9.6 – annotations stopped working and despite TRACE logs, silent failures from what we could tell.

Upgraded to 9.7 LTS fixed the issue and our annotations are working again with no other known changes to the system or CI pipeline! We have to conclude some issue in the 9.6 version.

Good Luck!

We also upgraded last week to the latest version and suddenly the annotations work again without changes. So definitely something broken in 9.6

1 Like


I tried to replicate the bug, unsuccessfully.

Steps that I took:

  1. Set up a SonarQube 8.9 version with PostgreSQL and integrated with a local Bitbucket server.
  2. Created a simple project in Bitbucket, imported it in SonarQube and ran PR analysis with decoration successfully.
  3. Upgraded SonarQube to 9.6 successfully.
  4. Created a new PR for the original project and PR decoration still works.
  5. Created a new project in Bitbucket, imported in SonarQube and PR decoration still works.

With the information that we have, I have no clues to continue the investigation.
If you can think of any other information that could help us identify the issue, feel free to reopen the discussion.