Portfolios lost in migration from 8.9 to 9.9 LTS


We are migrating our Sonarqube Enterprise from 8.9 to 9.9 and all data is migrated correctly except the Portfolios that are lost. We also tried migrating to 10.X but got the same result.

  • Our original server is Ubuntu Server 20, and we are migrating to a new kubernetes arquitecture were we use the Helm Charts to install Sonarqube.
  • We updated our enterprise licence (the serverID changed in the upgrade process).
  • We made a dump of our old database, copied it to the new deployment and completed the migration process that Sonar provides the first time you access to the interface after the migration. All the “database migration” process is done without any errors from Sonar, but the Portfolios are lost in the process (we even looked at the migrated postgresql table and it is empty, in the original database we have all our portfolios).

Is there any known bug with it? Are we making any mistake in the upgrade process? copying the data of the portfolio table directly from source to the migrated database will be enough to solve the issue?

Thanks for your support,


Welcome to the community!

You say that after your upgrade the relevant DB table is empty. Can you confirm that it’s non-empty before the SonarQube upgrade?

Also, what table are we talking about?

Without dredging through Jira, I know that portfolios used to be stored in an… unfortunate format and I believe we cleaned that up in recent versions. So if your “lost” is based on an empty DB table, you may be looking in the wrong place. Just to ask the dumb question: are they missing from the UI?


Hi Ann, and thank your for your answer.

Yes, the portfolios are missing from the UI, and we also looked at the DB table and it is empty (I don’t remember its name but will ask for it).

But first of all we’ll look at the dump, maybe as you say the data is not even there! I’ll update this ticket after we have checked that.


1 Like

Hi again Ann.

After analyzing the original dump, there is no portfolio table exported, so the problem was in the dump itself. We still don’t know why that data is not exported to the dump but that was the problem (we’ll analyze it deeply).

Sorry for the disturbance and thanks again.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.