Parsing issue with TI compiler

Hi there, I am using Sonarqube -8.6.1.40680. I get this crash:

INFO: EXECUTION FAILURE
INFO: ------------------------------------------------------------------------
INFO: Total time: 1:45.941s
INFO: Final Memory: 79M/280M
INFO: ------------------------------------------------------------------------
ERROR: Error during SonarScanner execution
java.lang.IllegalStateException: java.nio.file.NoSuchFileException: C:\Users\CARDIA~1\AppData\Local\Temp\probe2160877324278972826.pp
at com.sonar.cpp.fs.FileSystemAccess.toByteArray(FileSystemAccess.java:225)
at com.sonar.cpp.fs.FileSystemAccess.toString(FileSystemAccess.java:198)
at com.sonar.cpp.analyzer.TexasDriver.lambda$probeCompiler$1(TexasDriver.java:227)
at java.base/java.util.HashMap.computeIfAbsent(Unknown Source)
at com.sonar.cpp.analyzer.TexasDriver.probeCompiler(TexasDriver.java:206)
at com.sonar.cpp.analyzer.TexasDriver.onCapture(TexasDriver.java:101)
at com.sonar.cpp.plugin.CFamilySensor.process(CFamilySensor.java:523)
at com.sonar.cpp.plugin.CFamilySensor.execute(CFamilySensor.java:357)
at org.sonar.scanner.sensor.AbstractSensorWrapper.analyse(AbstractSensorWrapper.java:48)
at org.sonar.scanner.sensor.ModuleSensorsExecutor.execute(ModuleSensorsExecutor.java:85)
at org.sonar.scanner.sensor.ModuleSensorsExecutor.execute(ModuleSensorsExecutor.java:62)
at org.sonar.scanner.scan.ModuleScanContainer.doAfterStart(ModuleScanContainer.java:82)
at org.sonar.core.platform.ComponentContainer.startComponents(ComponentContainer.java:137)
at org.sonar.core.platform.ComponentContainer.execute(ComponentContainer.java:123)
at org.sonar.scanner.scan.ProjectScanContainer.scan(ProjectScanContainer.java:393)
at org.sonar.scanner.scan.ProjectScanContainer.scanRecursively(ProjectScanContainer.java:389)

I disabled the firewall and anti virus as suggested but this did not help.

attached are my JSON files and logs.build_wrapper.zip (366.2 KB)

thank you in advance,

kind regards,
Neil

Hi, after adding -X, we see
argument to option -mv (nops) is out of range
as the error.
can you help us fix this ?
thanks, neil

Hi @neillangmead ,

Welcome to SonarSource community! :sonarsource:

Can you attach the entire Sonar scanner debug-level logs?

Joe

Hi Joe, I worked around the issue. After building with debug (-X), I saw the scanner wasn’t happy with the -vMap option processing, so I deleted this from the JSON wrapper file, and the analysis completed successfully. It might be worth documenting the workaround in case other TI users come across this issue. thank you!
kind regards,
Neil

1 Like

@neillangmead : Thank you very much for explaining how you solved it. Please feel free to open a new thread in case you run into any new issues.

Joe

Hello @neillangmead,

It would help us if you can send the part of the debug log that mentions the -vMap command line option, so that we can correct the way it is handled.

I created https://jira.sonarsource.com/browse/CPP-2929 to track this issue.

1 Like

hi @JolyLoic , sure no problem, here is the log.output.zip (567.9 KB)
the issue was with error: argument to option -mv (nops) is out of range
Change in the JSON build script, the -mV option to the map file, and it works correctly.
thank you,
neil

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.