Not able to override http.nonProxyHosts in 9.9 LTS Version

Make sure to tell us:

  • What version are you upgrading from?
    8.9 to 9.9
  • System information (Operating system:K8s, Java version:17, Database:postgres 14)
  • What’s the issue you’re facing?
    i want to pass wild card domain in jvmOpts: -Dhttp.nonProxyHosts=localhost|127.|[::1]| but it is always taking default value localhost|127.*|[::1] not appending the domain

Hey there.

If this is about SonarQube-side configuration, you need to set this in the conf/ file or via environment variables, and not through some JVM option.

Hi Colin Thank for your reply im using sonar helm chart as per the documentation im setting the jvm_opts through values.yaml what i noticed is -Dhttp.nonProxyHosts is appearing twice in logs one with default value -Dhttp.nonProxyHosts=localhost|127.|[::1] and one with which is passed through values|localhost|127.*|[::1] due to which jenkins webhooks are failing

Here you should be using sonarProperties.

How to use it via helm chart can you provide any example please?