Jenkins job failing for sonarqube behind proxy - Server Unreachable

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    SonarQube - 8.4.1 Build 35646 Community Edition
    SonarScanner - 4.5.0.2216
    JDK - java-11-openjdk-devel

  • what are you trying to achieve
    1.) We are trying to achieve force user authentication and enabling it results in failure of webhook.

2.) We are running jenkins job which hits the haproxy virtual ip which has sonarqube behind it.

  • what have you tried so far to achieve this

We tried the below things , however it is not working
1.) Added sonar.ce.javaOpts=-server -Xmx4G -Xms512m -Xss1G -XX:+HeapDumpOnOutOfMemoryError -Dhttp.nonProxyHosts=jenkins.domain.com
(Ref:- Sonar Webhook unreachable)
in sonar.properties file
2.) Added http.proxyHost=haproxy_virtual_ip inside sonar.properties and the same was added with https
3.) Also Added http.nonProxyHosts=“jenkins.domain.com|localhost|127.|[::1]|.domain.com”
(http.nonProxyHosts has no effect, webhook delivery failing (CE 7.9.1 build 27448))
However, none of the above options have worked.

I would request you all to please help us with this scenario so as to get the jenkins job running.

Hello @AnupKulkarni
welcome to SonarSource community.
You will get more details about what is happening in the DEBUG logs enabled for SonarQube Compute Engine. Feel free to share the relevant lines here.

Such issues are frequently caused by self-signed certificates. In that case you may need to add your own root certificates to the cacert of your SonarQube JVM, and you’ll find many threads related to this in the community.
Let us know.

Best.
Sylvain