Migrating to saml / not authorized to access this page

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    SonarQube (Enterprise license)

  • how is SonarQube deployed: zip, Docker, Helm
    Azure App Service

  • what are you trying to achieve
    Setting up new saml authentication with Azure AD.

  • what have you tried so far to achieve this
    I have tried to login with my test user, but I am getting this “You’re not authorized to access this page. Please contact the administrator.” When testing the SSO in Azure Enterprise Application, I am getting “Sign-in succeeded, but 1 claims weren’t issued in the token. This can happen when there’s no value stored in the directory for the attribute. Please make sure the user *** has a value stored in the directory for the missing claims.”

Any suggestions here, has anyone had this type of challenge before? Thanks!


My impression from searching is that this is about the configuration on the Azure side. Maybe the docs will help…?


1 Like

Got it to work. Thanks for the feedback. Some wrong claims configuration in Azure.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.