Main branch is not analyzed C++/git

Version: Sonarqube v.
Achieve: Basic analysis of C++ project

I have a project where I have cloned a repo that has several branches. I have checked out a specific branch (lets call it myBranch) and built it under the linux wrapper using the command:
build-wrapper-linux-x86-64 --outdir . /usr/bin/make build

Then from the top directory of my clone I run sonar scanner. It appears to run successfully. Next I bring up the Sonarqube GUI and lo, and behold my project is on the list! Yay!..but it states “main branch has not been analyzed”. What gives? I tried changing the name of main (defaulted to master), to the name of the branch I had checked-out, built, scanned (myBranch) but this seems to have no effect. What am i missing?
(Before you ask, because of the classified nature of my work I cant give precise details of my branch structures etc.)


Welcome to the community!

First, I don’t see a clean in there. Is this a full clean/re-build?

Second (and this is probably not it) could you try creating a subdir for the build wrapper files?

And finally, can you redact your analysis log as necessary and share it?