Login with Sonarqube Not working

github
authentication

(Jose Alvarez) #1

when i enable the settings for github login i get a 404 this is not the page your looking for from github… ?? any ideas what might be the issue?


(Julien Lancelot) #2

Hi,

If you’re using github.com, you should not configure any URL of the github instance.
So the first 2 settings should be empty.

Regards


(Jose Alvarez) #3

Hi Julien,
I tried to leave the fields empty however it would not let me and gave me a warning message in red saying
(Validation failed. Provide a value or use “Reset” to set the value to the default one.)

Just some additional background info on my settings i have Enable GitHub users to login set to True and my Client ID and Client Secret are also loaded with the values i got from github… not sure what im doing wrong?
thx,
jose


(G Ann Campbell) #4

Hi,

Validation failed. Provide a value or use “Reset” to set the value to the default one.

What this error message is trying to tell you is that empty is the default value, and to “Reset” back to that, you need to use the explicit “Reset” button you see in the UI.

Ann


(Jose Alvarez) #6

Ok i tried that but its still not working when i click on github logon nothing happens… (the page just blinks/reloads) not sure if i need to change the github API enpoint url at the bottom? This is a private repo and im not even sure where to get that url…
thx,
jose


(Colin Mueller) #7

Jose,

Can I suggest listing your organization, VolusionDev, under the sonar.auth.github.organizations setting?

Colin


(Jose Alvarez) #8

Just tried adding VolusionDev and restarted sonarqube then tried it and i got the same thing when i click on the Login with github button on the home page just blinks and does nothing


(Jose Alvarez) #9

I think i got it… working i failed to add the server base url… that step is not in the documentation but its on the gui bullets
will test and let you know


(Jose Alvarez) #10

ok, we are making progress, i added the server base url and i had one of my co-workers try it out and he got the screen shot i posted below… i actually got the same one and when we click on it the green (authorize jose-alvarez-volusion) button it takes you back the sonarqube home page (but your not logged in) the user cannot log in with github creds. Shouldnt the user be automatically logged into the app?

thx,
jose


(Jose Alvarez) #11

Does any one have any idea what other configs i may need to add or change to make it possible for github users to log on to my sonarqube box?
thx
jose


(Jose Alvarez) #12

Hi Colin,
I am still having issues getting this to work… as described in the rest of the threads… basically i added - listed the orgs and the sonar base url and the first time i clicked on it it showed the images i pasted below that says Authorize sonarqube but after i clicked on that it went back to the login page and didnt log me in
not sure what the behavior is supposed to be like but i assumed it would just log me in?
thx,
jose


(Jose Alvarez) #13

nevermind i figured it out


(Colin Mueller) #14

Jose,

Can you share what the problem was so that somebody else facing the same problem might find the solution? I’m also curious myself.

Colin


(Jose Alvarez) #15

Colin,
Yes sure… i noticed the url message would rapidly change but for a brief moment indicated that there was a uri mismatch error. So i went back into github and there was a typo in the OAuth callback address which was causing it to fail… once i matched up the call back and the base url in the Admin>General settings it worked like a charm…
thx,
jose


(Patrick Delaney) #16

I’ll have to check my notes. But I will add what I discovered. I probably forgot to do it