Last analysis failed: AW4EIpwnje0MfGYyGHBP

  • ALM used: GitHub
  • CI system used : none
  • Scanner command used when applicable: using autoscan
  • Languages of the repository: PHP (CakePHP specifically)
  • Error observed: No errors that I can find but that the last analysis failed with code: AW4EIpwnje0MfGYyGHBP

I have linked a github repo to my sonarcloud account. It finds it, the sonarcloud app is installed on github. I added the files with a few folders excluded (first attempt was with an empty properties file). It keeps failing with the same message that the analysis failed (no details)

My properties file looks like this (I assume multiple folders should be separated by commas… the documentation doesn’t specify):

Path to sources

sonar.exclusions=files,import,deploy_scripts,cakephp @ f1db013,.gitignore,.git_workflow.ini,lib,.gitmodules

Path to tests


Source encoding


Exclusions for copy-paste detection


1 Like

I have been trying some other things and now my analysis failed with a new code:

I have looked in the ‘Background Tasks’ section like some other threads indicated but there isn’t anything listed in there.

1 Like

More failed attempts, new code is AW4ETR5-UTCRSHFyfPe9

No results in the Background Tasks section.

Anyone? I feel like I have my hands tied behind my back on this .

On Backgroud Tasks there is a button, which allows you to see the logs:


Without error logs (`Show Error Details) nobody is able to help you.

Second thing, I believe that people are ignoring your help request, because you posted analysis ID (three times) as error codes. There are many help requests, many are the same, so when community users see that:

  • product name is spelled incorrectly
  • basic information are missing, example:
    • version of: SonarQube, plugins, SonarScanner
    • full project configuration
  • lack of understanding of the product (example: error code = analysis id)
  • the same question was asked dozens of times

Then they just skip it. If you use search:

You will find that the most common answer is:


1 Like

Thanks @agabrys for chiming in. Unfortunately it seems you overlooked an important element in the user’s post: he did check the Background Tasks page and found nothing there. Please read more carefully next time, and I personally found your tone unfriendly.

Second thing, we (SonarSource team) were not ignoring the request, we’re just overloaded. The “last analysis failed” type of help requests are following a direct advice from SonarCloud itself, when it happens. So, for one thing, we certainly won’t ignore these, and for another thing, we should really improve the product to make these cases rare events.

@BenOberholzer Our investigation is in progress. For now, I can just tell you that some files appear to have invalid UTF-8 characters. I will share with you the list in a private message. But why do we care about UTF-8 you might ask. We try to detect the right encoding, and for these files we couldn’t, and in such cases we fall back on UTF-8 as default. If that’s not the correct encoding for your project, then you can set sonar.sourceEncoding=... in your file to the correct one.


Many thanks, Janos. You have been very helpful and I appreciate your response!

1 Like

Hello @janos, I didn’t want to be rude/unfriendly. If my answer sounded like that, I apologize. I just wanted to point that if somebody from support/community has some free time and dozen of requests, then he/she will pick up this one which a lot of details. Why? Because it has a higher chance to be solved :wink:

I didn’t miss it :wink: I read:

For my understanding it doesn’t mean that there is no error. Maybe there is an error, but the error message doesn’t point directly to the problem. I don’t know, I don’t see it

If SonarSource team read all help requests, then it is really cool :partying_face:

Great that the problem has been solved :+1:

Have a nice week :slightly_smiling_face: