Jenkins trying to pull last sonar state when browsing a job, making jenkins TMOUT

Hi Community!
I run into an issue that took me a while to find the cause. A user reported that was unable to access a jenkins’s job via its browser, effectively the job was timing out. Checking Jenkins logs I found out:

Error fetching project information connect timed out
	at Method)
	at okhttp3.internal.platform.Platform.connectSocket(
	at okhttp3.internal.connection.RealConnection.connectSocket(
	at okhttp3.internal.connection.RealConnection.connect(
	at okhttp3.internal.connection.StreamAllocation.findConnection(
	at okhttp3.internal.connection.StreamAllocation.findHealthyConnection(
	at okhttp3.internal.connection.StreamAllocation.newStream(
	at okhttp3.internal.connection.ConnectInterceptor.intercept(
	at okhttp3.internal.http.RealInterceptorChain.proceed(
	at okhttp3.internal.http.RealInterceptorChain.proceed(
	at okhttp3.internal.cache.CacheInterceptor.intercept(
	at okhttp3.internal.http.RealInterceptorChain.proceed(
	at okhttp3.internal.http.RealInterceptorChain.proceed(
	at okhttp3.internal.http.BridgeInterceptor.intercept(
	at okhttp3.internal.http.RealInterceptorChain.proceed(
	at okhttp3.internal.http.RetryAndFollowUpInterceptor.intercept(
	at okhttp3.internal.http.RealInterceptorChain.proceed(
	at okhttp3.internal.http.RealInterceptorChain.proceed(
	at okhttp3.RealCall.getResponseWithInterceptorChain(
	at okhttp3.RealCall.execute(
Caused: java.lang.IllegalStateException: Fail to request https://sonarqube-legacy.url/api/ce/task?id=AYaANsjxbLEQIcp9XcS0

Searching a bit on google I found out that apparently when you browse a job or API query it, it will try to get the last sonar result from the build. Since this instance was decommission I believe its whats causing the problems. The question is, anyone knows how can I bypass that “check” jenkins does against sonarqube?

This was reported here

  • Jenkins Sonar Plugin Version: 2.14
  • Jenkins Instance: 2.249.1

Best Regards!


Can you try removing the SonarQube analysis from the job configuration?


Hi Ann,
I think I solved it a couple of hours ago as you mention. I had to remove the sonar analysis lines from the last build of the job, like:

<hudson.plugins.sonar.action.SonarMarkerAction plugin="sonar@2.14"/>
    <hudson.plugins.sonar.action.SonarAnalysisAction plugin="sonar@2.14">

After removing such line I had to reload the Jenkins job, I did it via console script with

Jenkins j = Jenkins.get()
def job = j.getItemByFullName("PROJECT_NAME")


That did the trick!
Thanks for your support.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.