Java 11 Error in Console

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this
    I am trying to use the developer SonarQube download and I have also tried the Community version and get the same results.

After download I am getting this error in my console when I run the sonar.bat file.

I have tried looking for the java 11 download but unable to find it.
Does SonarQube have a download that is safe to use for these products?


Hello @schall,

Welcome to the SonarSource community. :wave:. We hope you’ll enjoy it.
To solve your problem you must meet the basic requirement to first install Java 11 on your machine (JRE or the more comprehensive JDK). You can download a JDK:

(There are plenty of other places, the above is not a recommendation, just a suggestion, for instance the AdoptOpenJDK).


Great! Thank you @OlivierK . This is helpful I was guided to a lot of spam websites when Googling Java 11 download. I will start from here thank you!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.