Issue with 10.4 saml image reference

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension): 10.4
  • how is SonarQube deployed: Helm
  • what are you trying to achieve: Upgrade to 10.4 from 10.2
  • what have you tried so far to achieve this: Attaching the error image and reference url for image load

Hey there.

I can’t reproduce this.

Can you share how your Helm chart is configured?


this is the chart:

apiVersion: v2
name: sonarqube
description: SonarQube
type: application
version: 0.5.0
appVersion: “10.4.0”


Colin - Do let me know if you need any additional details? Did you try the same build as the one above in chart config?

Good day, Colin.

Thank you for your assistance.

I believe the configuration affecting “saml.png” is as follows:
sonarWebContext: “/sq”
enabled: true

- name: ***
path: /sq

We serve sonarqube from /sq, and I think you may be missing an environment variable in your front end for this particular png:

Here is the logo that works(note /sq/ in front of it):

Hope that helps, thanks!

Hey @VDubrovenski

This seems more likely – that the web context is getting in the way.

Are you working with @suhas-arcadis? Is this the real chart config?

Yes sir and this is a real chart config(just removed url and unnecessary info)…

1 Like

Hello @suhas-arcadis and @VDubrovenski,

Thank you for reporting the bug and welcome to the community. I will take a look into this issue.


1 Like

The issue has been fixed and the fix will be available in SonarQube v10.5.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.