Issue : Quality Gate failed: Compute engine task did not complete within time

The same in our entire organization.

1 Like

affecting my entire org as well.

Same issue reported in these threads:

having the same issue, like for everybody else started around 2pm ET and still is not working

Same issue :confused:

We have the same issue :sob:. The last analysis failed with memory heap error and then all others have already been queued and are in pending status

Same issue with us, all our tasks are pending.

how do you do that?

@Anshuman_Goyal to enable debug mode add -X to the scanner command line:

usage: sonar-scanner [options]

 -D,--define <arg>     Define property
 -h,--help             Display help information
 -v,--version          Display version information
 -X,--debug            Produce execution debug output

I posted a tweet, probably my first ever. Please retweet, that might get their attention.

1 Like

Done, it seems to be motionless.

Same issue. Entire org wide scans stalled in all of our pipelines.

same here, no response whatsoever.

I received an email from SonarSource, they are now aware customers are experiencing issues.

1 Like

I finally got sick of this happening so added a feature flag to my Azure Pipeline sonarcloud Tasks.

I documented here for anyone else interested:

Having the same problem in Travis CI builds - everything runs fine (no errors in the Travis logs), but the report processing status is always PENDING and the dashboard in sonarcloud does not update existing branches or add new PRs.

Same issue


Task : Publish Quality Gate Result

Description : Publish SonarCloud’s Quality Gate result on the Azure Pipelines build result. To be used after the actual analysis.
Version : 1.9.0
Author : sonarsource
Help : More Information

##[error][SQ] Task failed with status FAILED, Error message: Java heap space
Finishing: Publish Quality Gate Result

To remeidate that i manually exported environment variable using bash script as
export SONAR_SCANNER_OPTS="-Xmx3062M"
export SONAR_RUNNER_OPTS="-Xmx3062M"

Even added below lines in Prepare SonarCloud analysis steps as well

Even using powershell to manually add this property in
(Get-Content D:/a/1/.sonarqube/out/ | ForEach-Object { $_ -replace “-Xmx1024M”, “-Xmx3192M” } | Set-Content D:/a/1/.sonarqube/out/

Still it is not working. Using Azure pipeline Windows 2019 agent and tried with hosted VS2017 agent as well.

Tried verbose and not getting any logs in publish task(publish quality gate). As checked it Run was using 1024m

This is getting quite ridiculous, no response what so ever for more than 24 hours on a critical issue that is blocking many users. This is unheard of. #bug #bug #bug

24 hours, background tasks stilling going to the abyss!

I can just reiterate what others have said. All our builds in our GitHub organization is blocked by this. No analysis has completed in 24+ hours and there’s now long queues of pending jobs.