Issue filters data is corrupted in SonarCloud

Yesterday, I excluded several folders and deactivated a bunch of rules in our Quality Profile. This has vastly reduced the amount of issues that I find in a certain project. Many of the previous issues are now in state “Closed (Removed)”. However, when I go to the Issues page and try to filter the issues, the filters seem to have inconsistent data. The issues that are in state “Closed (Removed)” still show up in the “Open” status in the filter, which makes it very difficult to work with the issues.

Here’s a screenshot demonstrating one of the issues:

Other filters are also not correct, I think the filtering index is somehow broken and corrupted and I don’t know what to do to make it recompute the data. Right now, the filtering is completely unusable as it incorrectly shows issues from excluded code or deactivated rules and shows wrong filter counts, etc.

Can you please re-compute the filtering data for this project somehow?

  • I tried running many full-repository analysis and also leaving it overnight, but nothing has helped.
  • I also cannot change the issues at all (re-open and close them again).
  • I cannot share much more publicly as all the code in our organization is private. If needed, I can provide details about the organization and project privately.

We’re using SonarCloud paid plan with Azure DevOps integration and private organization with private projects.

Hi Tomas,

Welcome to the Sonar community!

Thanks for raising this issue with so many details. I asked for the project key and the organization key in a private thread.

Could you also give me a bit more details about the changes you made in the configuration, for me to try to reproduce the behavior? I would like to understand if we missed something when handling removed issues, versus a transient indexing error.

To try to fix it while we investigate, I would suggest reverting the configuration changes you did and running an analysis of the branch.
It should re-open all the closed issues.
And then, re-apply your changes and analyze the branch again. It will close the issues again, and if it was a transient error on our side, it should update the filters accordingly and solve the issue for you, while I’ll continue investigating the root cause on my side. In both cases, it will give very valuable information for my investigation.

Thanks in advance,

Actually, I managed to resolve the other day.

I got an idea that I could try to re-activate all the rules, and remove all the exclusions. Then I ran a full analysis which re-opened the previously “Closed (Removed)” issues.

And then I deactivated these rules again and added exclusions and ran full analysis, and after that, the filter data was consistent and correct.


Thanks a lot, Tomas for providing your resolution, it helps a lot! I see it is a transient sync error on our side, I’ll continue the investigation to solve the root cause.


1 Like

Thanks to the provided details, I was able to identify a race condition on our side causing this data inconsistency, and a few areas of improvement to be able to solve it more easily.

I’ll open some internal tickets to fix those.
Thanks again @oswtpazourek for raising that issue, and helping us improve our product!


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.