Invalid Azure server URL or Personal Access Token for ALM integration

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!

SonarQube Version - 8.9 LTS.
JAVA - JDK 17
os- Windows server
Azure DevOps - Azure DevOps server 2019.

I tried ALM integration of Azure devops server in Sonarqube server. I have provided proper URL and PAT tokens with different permissions, but still it is throwing error as invalid url and PAT.

I had checked IIS basic authentication in azure DevOps server, it has been off mode.
Could you please help me on this.

Hi,

Welcome to the community!

Java 17 isn’t supported for SonarQube 8.9. It may be irrelevant to your issue, but it would be best to downgrade to a supported version.

If you’re certain the values you’ve provided are correct, then you should talk to your network folks. Is there something “helpful” in between interfering with communication between SonarQube and ADOServer?

 
HTH,
Ann

Thnaks G Ann Campbell,

Which java version is suitable for SonarQube 8.9 LTS.?

Hi,

Per the docs you need Java 11.

 
HTH,
Ann

I had gone through the document. Jave 17 is supporting for SonarQube 8.9 LTS version.

Is there any port required to open between SonarQube Server and Azure Devops server. except 443.

Hi,

Did you read the LATEST docs or the ones specific to your version, as I linked above?

 
Ann

Hi,

Thanks,

I had installed java 11 also, but again i am facing same problem,

could you please guide me end to end process, like installation and configuration and connection among azure devops server.

Hi,

I can only point you to the docs.

I assume you mean this initial report?

For that, I can only tell you to triple-check your values and maybe talk to your network folks to make sure they’re not blocking the communication.

 
Ann