Installation 7.7 not working

sonarqube

(Dallas Stephens) #1
  • SonarQube 7.7
  • Trying to achieve installation of the product and it’s not working
  • I need contact either through email or phone.

(Colin Mueller) #2

Hey Dallas,

In case you missed this part of the template for your post, I’ve shared it below

what have you tried so far to achieve this

What specifically is not working? When does it fail? I would consider checking out the Troubleshooting documentation and come back with anything interesting from the logs.

Colin


(Dallas Stephens) #3

sudo yum install wget -y
wget http://repo.mysql.com/mysql-community-release-el7-5.noarch.rpm
sudo rpm -ivh mysql-community-release-el7-5.noarch.rpm
sudo yum update -y
sudo yum install mysql-server
sudo systemctl start mysqld
sudo mysql_secure_installation

Set root password? [Y/n] Y
Remove anonymous users? [Y/n] n
Disallow root login remotely? [Y/n] n
Remove test database and access to it? [Y/n] n
Reload privilege tables now? [Y/n] Y
mysql -u root -p
SHOW GLOBAL VARIABLES LIKE ‘storage_engine’;
CREATE USER ‘sonarqube’@‘localhost’ IDENTIFIED BY ‘password’;
CREATE DATABASE sonarqube;
GRANT ALL PRIVILEGES ON sonarqube.* TO ‘sonarqube’@‘localhost’;
sudo vi /etc/my.cnf
query_cache_size = 15M
innodb_buffer_pool_size = 1280M
wq!
sudo wget https://sonarsource.bintray.com/Distribution/sonarqube/sonarqube-7.7.zip
sudo yum install unzip -y
sudo yum install java-1.8.0-openjdk -y
sudo unzip sonarqube-7.7.zip
sudo mv sonarqube-7.7 sonarqube

cd /opt/sonarqube/conf/
sudo vi /opt/sonarqube/conf/sonar.properties
sonar.jdbc.username=sonarqube
sonar.jdbc.password=password
sonar.jdbc.url=jdbc:mysql://localhost:3306/sonarqube?useUnicode=true&characterEncoding=utf8&rewriteBatchedStatements=true&useConfigs=maxPerformance
sonar.web.host=xxx.yyy.zzz.abc (<—I masked real IP here to not show in this update)
sonar.web.port=80
sonar.web.context=/sonar (NEED TO VALIDATE THIS)
sudo vi wrapper.conf
wrapper.java.command=/usr/bin/java
cd /opt/sonarqube/bin/linux-x86-64
sudo ./sonar.sh start

RESULTS OF ./SONAR.SH CONSOLE
[myuname@location@servername linux-x86-64]$ sudo ./sonar.sh console
Running SonarQube…
wrapper | --> Wrapper Started as Console
wrapper | Launching a JVM…
jvm 1 | Wrapper (Version 3.2.3) http://wrapper.tanukisoftware.org
jvm 1 | Copyright 1999-2006 Tanuki Software, Inc. All Rights Reserved.
jvm 1 |
jvm 1 | 2019.04.01 11:13:37 INFO app[o.s.a.AppFileSystem] Cleaning or creating temp directory /opt/sonarqube/temp
jvm 1 | 2019.04.01 11:13:37 INFO app[o.s.a.es.EsSettings] Elasticsearch listening on /127.0.0.1:9001
jvm 1 | 2019.04.01 11:13:37 INFO app[o.s.a.p.ProcessLauncherImpl] Launch process[[key=‘es’, ipcIndex=1, logFilenamePrefix=es]] from [/opt/sonarqube/elasticsearch]: /opt/sonarqube/elasticsearch/bin/elasticsearch
jvm 1 | 2019.04.01 11:13:37 INFO app[o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
jvm 1 | 2019.04.01 11:13:37 INFO app[o.e.p.PluginsService] no modules loaded
jvm 1 | 2019.04.01 11:13:37 INFO app[o.e.p.PluginsService] loaded plugin [org.elasticsearch.transport.Netty4Plugin]
jvm 1 | 2019.04.01 11:13:38 WARN app[o.s.a.p.AbstractProcessMonitor] Process exited with exit value [es]: 1
jvm 1 | 2019.04.01 11:13:38 INFO app[o.s.a.SchedulerImpl] Process [es] is stopped
jvm 1 | 2019.04.01 11:13:38 INFO app[o.s.a.SchedulerImpl] SonarQube is stopped
wrapper | <-- Wrapper Stopped


(Colin Mueller) #4

Dallas,

In your install directory, in the logs folder, you’ll likely find some more insightful logs. Specifically I would be interested in the es.log file, where I am willing to bet around $1 that it’s letting you know you cannot start SonarQube as root! I think there’s a RUN_AS parameter in the same wrapper.conf you edited.

Also, I’m obligated to recommend choosing a database platform other than MySQL. Postgres is a good free alternative.

Colin


(Dallas Stephens) #5

You are correct. There are messages that say you Cannot run Elasticsearch and SonarQube as root. So what is the fix for that on Linux Redhat? Editing the Wrapper.conf file? I don’t see that value in the wrapper.conf file.


(Colin Mueller) #6

Perhaps check out the sonar.sh file in the appropriate /bin/ directory for your OS


(Dallas Stephens) #7

It was permissions of the default installation directory. So we have that sorted out. Thank you


(Dallas Stephens) #8

One last question I made progress through connections issuesc disabled the unit tests for now to see if the maven task passes and writes the results to SonarQube. Then ran into sonar-maven-plugin not found in the log so I updated the POM by adding the dependency below and still getting below error. Let me know your thoughts???

org.sonarsource.scanner.maven sonar-maven-plugin 3.6.0.1398
  1. [ERROR] Failed to execute goal org.sonarsource.scanner.maven:sonar-maven-plugin:3.6.0.1398:sonar (default-cli) on project CompanyConnect: Validation of project reactor failed:

  2. [ERROR] o To use the property sonar.branch.name, the branch plugin is required but not installed. See the documentation of branch support: https://redirect.sonarsource.com/doc/branches.html.

[ERROR] -> [Help 1]


(G Ann Campbell) #9

Hi,

You’ve already created another thread for this issue

So we’ll consider this one closed.

 
Thanks for understanding,
Ann


(Dallas Stephens) #10

Stephens, Dallas would like to recall the message, “[SonarSource Community] [Get help/SonarQube] Installation 7.7 not working”.
Disclaimer: This email and any attachments are sent in strictest confidence for the sole use of the addressee and may contain legally privileged, confidential, and proprietary data. If you are not the intended recipient, please advise the sender by replying promptly to this email and then delete and destroy this email and any attachments without any further use, copying or forwarding.